ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Goktepe" <andrewgokt...@gmail.com>
Subject Re: [Copying of a file] Issue
Date Fri, 15 Dec 2006 15:01:55 GMT
In your Ant output, I don't see any calls to the targets you provided. It
looks like your error is occuring in some other target (maybe scanlogs).

Go to line 94 in your script to see if you're looking at the right target.

-Andrew

On 12/15/06, Dharmesh Vyas <dharmesh.mail@gmail.com> wrote:
>
> Hello Group,
>
> I am trying to call one target from another and while calling the other
> target I am passing a parameter value which is to be used in the called
> target. Here it is what I am doing.
>
> <target name="one" description="debug binaries">
> <antcall target="copylogs">
>   <param name="logs" value="debuglogs.txt"/>
> </antcall>
> </target>
>
> <target name="copylogs" description="copying the logs for the failures">
>   <copy file="${basedir}\logs\${logs}"
> tofile="${basedir}\filestobesent\${logs}"/>
> </target>
>
> After running the target it the copying of the file happens successfully
> but
> it thows an error as shown below.
> *ERROR:*
>
> ANT_HOME is set to = C:\Pooja\MyView\ATG_FIX\eprods\java\apache-ant-1.6.3
> Build sequence for target(s) `scanlogs' is [scanlogs]
> Complete build sequence is [scanlogs, fixprovider_d, debug, fixprovider_r,
> creat
> elogsdir, checkcondition, loadfiletoproperty, cdatetime, sendmail,
> release,
> all,
> temp, ]
> Entering C:\Pooja\MyView\ATG_FIX\base\ATG\FIX\ATG
> FIX\build\MyBuildTestEnv.xml..
> .
> Build sequence for target(s) `scanlogs' is [scanlogs]
> Complete build sequence is [scanlogs, fixprovider_d, debug, fixprovider_r,
> creat
> elogsdir, checkcondition, loadfiletoproperty, cdatetime, sendmail,
> release,
> all,
> temp, ]
>
> scanlogs:
> Copying 1 file to C:\Pooja\MyView\ATG_FIX\base\ATG\FIX\ATG
> FIX\build\filestobese
> nt
> Copying C:\Pooja\MyView\ATG_FIX\base\ATG\FIX\ATG
> FIX\build\logs\fixproviderdebug
> logs.txt to C:\Pooja\MyView\ATG_FIX\base\ATG\FIX\ATG
> FIX\build\filestobesent\fix
> providerdebuglogs.txt
> Exiting C:\Pooja\MyView\ATG_FIX\base\ATG\FIX\ATG
> FIX\build\MyBuildTestEnv.xml.
>
> debug:
>
> scanlogs:
> Property ${logs} has not been set
> Property ${logs} has not been set
>
> BUILD FAILED
> C:\Pooja\MyView\ATG_FIX\base\ATG\FIX\ATG FIX\build\MyBuildTestEnv.xml:94:
> Warnin
> g: Could not find file C:\Pooja\MyView\ATG_FIX\base\ATG\FIX\ATG
> FIX\build\logs\$
> {logs} to copy.
>        at org.apache.tools.ant.taskdefs.Copy.execute(Copy.java:394)
>        at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java
> :275)
>        at org.apache.tools.ant.Task.perform(Task.java:364)
>        at org.apache.tools.ant.Target.execute(Target.java:341)
>        at org.apache.tools.ant.Target.performTasks(Target.java:369)
>        at org.apache.tools.ant.Project.executeSortedTargets(Project.java
> :1216)
>        at org.apache.tools.ant.Project.executeTarget(Project.java:1185)
>        at org.apache.tools.ant.helper.DefaultExecutor.executeTargets
> (DefaultExe
> cutor.java:40)
>        at org.apache.tools.ant.Project.executeTargets(Project.java:1068)
>        at org.apache.tools.ant.Main.runBuild(Main.java:668)
>        at org.apache.tools.ant.Main.startAnt(Main.java:187)
>        at org.apache.tools.ant.launch.Launcher.run(Launcher.java:246)
>        at org.apache.tools.ant.launch.Launcher.main(Launcher.java:67)
>
> Total time: 1 second
>
>
>
> Please let me know If I am missing something over here.
>
> Thanks in advance,
>
> - Dharmesh Vyas.
>
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message