ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Sebastian Weber <sebastian.we...@outlawtrail.de>
Subject Ant 1.6.5 and JUnit task
Date Sat, 16 Dec 2006 00:27:40 GMT
Hi everybody,

I am sure that I am not the first one to post that particular question 
here, but I'm very close to snapping my keyboard in half, because I 
can't get it done.

I set up an Anthill build management server on a Fedora based linux 
system. The machine I am working on is a server on which I don't have 
full root access. Anthill is deployed in a JBoss 4.0.4.GA Patch1 JBoss 
server. I can check out my project from the SVN repository and build it. 
My Ant script deploys the build to JBoss, the connection to the DB is 
established everything fine. And then I try to run the JUnit tests via 
the script.

If I see that

"This is common and has a number of causes; the usual 
solutions are to read the manual pages then download and
install needed JAR files, or fix the build file: 
 - You have misspelt 'junit'.
   Fix: check your spelling.

[...]"


error message once more . . . 

I tried to put the junit.jar in the ANT_HOME/lib folder, I tried the same with a symbolic
link to junit.jar in that folder,
I tried to find the appropriate place for a CLASSPATH entry in one or another init or conf
script,
I tried to taskdef junit tasks (which switched the above error message to a "ClassNotFoundException"
for the test classes),
I even tried the new Ant 1.7.0RC1 which claims to solve that particular problem. Well, obviously
it does not, otherwise I would
not be begging for help.


I ran out of ideas and would appreciate any useful hint that might lead to a solution. Any
script where I can put the classpath
definition in, any location where I can copy the junit.jar, any useful webpage (other than
Ant FAQ...) or just ANYTHING!


Sebastian









---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message