ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From James Abley <james.ab...@volantis.com>
Subject Re: AW: please update the next release of Ant 1.7 to Xerces 2.9.0
Date Tue, 05 Dec 2006 08:24:37 GMT
Looks like it does...

http://svn.apache.org/viewvc/xerces/java/trunk/build.xml?view=markup

which uses an extended form of <javac/>

http://svn.apache.org/viewvc/xerces/java/trunk/tools/src/XJavac.java?view=markup

The class file version number (after pulling apart 
org.apache.xerces.impl.Version) is 45.3, which I think is good enough?

http://java.sun.com/docs/books/vmspec/2nd-edition/html/ClassFile.doc.html#75883

Cheers,

James

Jan.Materne@rzf.fin-nrw.de wrote:
>>> Next question for them: are the classes compiled for use on 1.2?
>>>
>> Well, I can't say for sure off the top of my head, but I can 
>> say one thing: it isn't any different than for Xerces-2.8.1, 
>> which Ant-1.7 currently depends on. 
> 
> Maybe from the sources content.
> A beta of AntUnit was compiled without source="1.2" argument so the
> compiler default was used
> (1.4 I think) ...
> 
> 
> Jan
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message