ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Robert Segal" <Robert.Se...@cryptologic.com>
Subject Ant error reporting issue when using XML log output through exec call
Date Wed, 13 Dec 2006 23:36:56 GMT
Hi all I'm having trouble getting proper error feedback when running ant
through an exec task that uses XML log file output.  Here is my current
setup....

<exec dir="." executable="${env.ANT_HOME}\bin\ant.bat"
failonerror="false" resultproperty="exec-result">
  <arg line="-f ./../../../Client/Build/build-flash.xml" />
  <arg line="-logger org.apache.tools.ant.XmlLogger" />  
  <arg line="-verbose" />
  <arg line="-logfile c:\cygwin\home\roberts\${logfile}" /> 
</exec>

Unfortunately when I run the task which encompasses this exec task it
always returns success.  Even if there are errors reported by running
the build-flash.xml I am running.  I am thinking this is something to do
with logging the output to an XML file as when I take out the XML
logging I do properly receive an error as a result of running
build-flash.xml.  I can even explicitly put a "<fail/>" task in the
build-flash.xml file and this exec call will still report a sucees.  Has
anyone encountered this problem before?  My lack of any experience is
preventing me from progressing.  Any help is appreciated.

Robert Segal
Sr. Tools Developer
CryptoLogic Inc.
55 St. Clair Ave W., 3rd Floor
Toronto, Ontario
Canada  M4V 2Y7
tel.  + 1.416.545.1455 x5896
fax. + 1.416.545.1454

This message, including any attachments, is confidential and/or
privileged and contains information intended only for the person(s)
named above. Any other distribution, copying or disclosure is strictly
prohibited. If you are not the intended recipient or have received this
message in error, please notify us immediately by reply email and
permanently delete the original transmission from all of your systems
and hard drives, including any attachments, without making a copy.


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message