ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <Jan.Mate...@rzf.fin-nrw.de>
Subject AW: ANT pb with jdk version
Date Fri, 24 Nov 2006 10:57:20 GMT
>My ear have to be compilated with a JDK 1.4 in order to be 
>deployed on my WAS server.

set the 'source' and 'target' attribute of <javac>.


>java.lang.UnsupportedClassVersionError: 
>com/sun/tools/javac/Main (Unsupported major.minor version 49.0)

That means, that a Java<=1.4 class (version 48) tries to instantiate a
class that
was compiled on Java5 (version 50). 

Usually you should try to compile the used class on the lower level.
But com/sun/tools/javac/Main is part of the JDK (tools.jar). So
recompiling is
not possible (yet ;-) But I think your JAVA_HOME points to Java5 and
therefore Ant adds
Java5's tools.jar to its classpath ...



Jan

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message