ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeremy Jardin <jeremy.jar...@gmail.com>
Subject ANT pb with jdk version
Date Fri, 24 Nov 2006 10:51:35 GMT

Hi,

I'm trying to write an ANT script to compile, package an EJB.ear.

My ear have to be compilated with a JDK 1.4 in order to be deployed on my
WAS server.
My script works well if I launch it with a JDK1.5, but the deployement
failed.

If I launch my script using a JDK 1.4, it doesn't work, and I have that
exception :

C:\Workspace\DEVPECAG2RManagerEJBClient\build.ag2r.ejb.client.xml:35:
java.lang.UnsupportedClassVersionError: com/sun/tools/javac/Main
(Unsupported major.minor version 49.0)

That happens at this line :
<ant antfile="../${ejb.client.name}/build.ag2r.ejb.client.xml"
target="package"/>

(I just launch subprojects packaging)..

I don't how to resolve that problem ?

ANy idea please ??
Thank you in advance.


-- 
View this message in context: http://www.nabble.com/ANT-pb-with-jdk-version-tf2697870.html#a7524075
Sent from the Ant - Users mailing list archive at Nabble.com.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message