ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <>
Subject Re: No supported regular expression matcher found
Date Thu, 05 Oct 2006 11:58:31 GMT
Hello Tina,

Tina Meier wrote:
> Hello,
> forgive me if this is obvious but i've been struggling with this for a few days and i'm
at the end of my wisdom.
> So: i would like to use ant to create an overview of my ivy repository (like described
at - in the last paragraph).
> Everything in my 'gen-content.xml' is like the one linked at ivyrep except the first
few lines. I had to modify them to get the antcontrib prefix working. My first lines are:
why do you do this ?
> <project name="ivyrep-gencontent" default="gen" xmlns:antcontrib="antlib:net.sf.antcontrib">
> 	<path id="ivy.lib.path">
> 		<fileset dir="/home/tina/opt/apache-ant-1.6.5/lib" includes="*.jar" />
> 	</path>
> 	<taskdef resource="net/sf/antcontrib/antlib.xml" uri="antlib:net.sf.antcontrib" classpathref="ivy.lib.path"
> <!-- rest is like -->
If your ANT_HOME is set to /home/tina/opt/apache-ant-1.6.5 and
/home/tina/opt/apache-ant-1.6.5/lib contains all the ant jars plus the
ivy jars, then you do not need the classpathref attribute next to your
By the way, if you want to load ant-contrib, why do you call the path
ivy.lib.path ?

Also if ant-contrib.jar is under /home/tina/opt/apache-ant-1.6.5/lib you
do not need the <taskdef/> at all to load ant-contrib. Ant will load
automatically the task definitions from ant-contrib from


> When i run this with 'ant -f gen-context' i end up with:
> /home/tina/opt/JavaLibraries/ivy-Repository/gen-content.xml:54: The following error occurred
while executing this line:
> /home/tina/opt/JavaLibraries/ivy-Repository/gen-content.xml:63: No supported regular
expression matcher found
> I don't understand this error because i use JDK 1.5 - therefore i shouldn't need some
3rd party libraries cause the regex funcionality is already in the JDK. However, i tried it
with the jakarta-oro & jakarta-regex packages too. Nothing helps, the error message is
always the one above.
> I use Ant 1.6.5 (binary distribution, downloaded from and installed to
> So if you have any ideas why this doesn't work _please_ enlighten me.
> Thanks a lot in advance.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message