ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dan McFadyen" <d...@cryptocard.com>
Subject RE: Weird Deleting Problems..
Date Thu, 14 Sep 2006 15:40:50 GMT

Sorry for the misunderstanding..

The file being deleted is on the local drive, the only stuff on the share is
ant and all the jar files we import that we don't build ourselves. Why it
should affect file deleting on the local machine I have no idea, but it
does.

Dan



-----Original Message-----
From: Scot P. Floess [mailto:floess@mindspring.com]
Sent: Thursday, September 14, 2006 10:09 AM
To: Ant Users List
Subject: Re: Weird Deleting Problems..


Dan:

How about writing a simple script to delete something off a shared drive?

Dan McFadyen wrote:
> I had copied the whole build environment to my machine before the switch
> over, and I replaced it, it's the same version of Ant, same library paths
> etc..
>
> The java runtime used is taken from each users local machine, which hasn't
> changed on the build system. The "ant -version" command returns the exact
> same value. The build system is a window XP machine.
>
> Another note: after several runs through the build script I have managed
to
> make it fail to delete something at a point earlier in the build script,
> which also hasn't changed... which has me more confused...
>
> Dan
>
> -----Original Message-----
> From: Antoine Levy-Lambert [mailto:antoine@gmx.de]
> Sent: Thursday, September 14, 2006 10:28 AM
> To: Ant Users List
> Subject: Re: Weird Deleting Problems..
>
>
> Hello Dan,
>
> this does sound weird.
>
> are you sure that the ant binaries that you are using now from the new
> network share are the same as previously ?
>
> is your java runtime the same as previously ?
>
> Regards,
>
> Antoine
>
> -------- Original-Nachricht --------
> Datum: Thu, 14 Sep 2006 09:41:32 -0400
> Von: "Dan McFadyen" <danm@cryptocard.com>
> An: user@ant.apache.org
> Betreff: Weird Deleting Problems..
>
>
>> Hello,
>>
>> I know this is probably going to be a rather odd problem but here goes...
>>
>> We have out Build Environment on a network share (Ant, Ant jars, compile
>> jars, etc) which just got replaced with a newer machine.
>>
>> Since that time the ant scripts have been failing while trying to delete
>> local files on the Build machine (the network share is mapped to another
>> drive letter on the same machine). The files being deleted are .class
>> files
>> that were just compiled, obfuscated and JARed moments before.
>>
>> I know this is probably some handle open to the file from ant which is
>> causing the delete to fail, and the only immediate difference I can see
is
>> that the new network share is faster than the old one. I tried sleeping
>> the
>> delete to see if that would make a difference, but it had no effect.
>>
>> Any ideas on how to solve this are welcome.
>>
>> Thanks,
>>
>> Dan
>>
>>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>
>

--
Scot P. Floess
27 Lake Royale
Louisburg, NC  27549

252-478-8087 (Home)
919-754-4592 (Work)

Chief Architect JPlate  http://sourceforge.net/projects/jplate
Chief Architect JavaPIM http://sourceforge.net/projects/javapim


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message