ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mark Modrall" <MModr...@glgroup.com>
Subject RE: ant and eclipse?
Date Fri, 29 Sep 2006 19:09:07 GMT
Not sure where I'd check that.  I know that ant is using jdk1.5.0.6 but
I don't know how to look into what eclipse is using...  

Thanks
-mark




 
This e-mail message, and any attachments, is intended only for the use of the individual or
entity identified in the alias address of this message and may contain information that is
confidential, privileged and subject to legal restrictions and penalties regarding its unauthorized
disclosure and use. Any unauthorized review, copying, disclosure, use or distribution is strictly
prohibited. If you have received this e-mail message in error, please notify the sender immediately
by reply e-mail and delete this message, and any attachments, from your system. Thank you.


-----Original Message-----

From: Shay Thompson [mailto:sthompso@adobe.com] 
Sent: Friday, September 29, 2006 2:53 PM
To: Ant Users List
Subject: Re: ant and eclipse?


The first thing I'd look at is what JVM is Eclipse using to compile the 
code vs. what JVM is used when on the command-line.

-Shay

Mark Modrall wrote:
> Hi...
>
>  
>
>             We do all of our development in eclipse and use ant 1.6.5
> for our nightly builds on another machine.  But someone just tried to
> invoke ant to run our junit tests on his dev machine.  He went into
the
> eclipse project directory and executed the ant build.xml file there,
but
> the javac task on the junit tests failed with a strange compile error
> against one of the base classes to be tested (a "bad class file" error
> on the use of generics).
>
>  
>
>             Finally narrowed it down to the fact that the .class files
> produced by eclipse aren't compatible with the class files produced by
> <javac>.  If I recompile the base classes from the command line using
> javac, then the junit test compiles.  The problem is that it's hard to
> map what options eclipse is using to javac commandline parameters, so
I
> can't tell what is causing the incompatibility.
>
>  
>
>             Eclipse has a Run As... option for ant projects but when I
> try to run it from inside eclipse, it says it doesn't know about
> <junit>.
>
>  
>
>             First, anyone know how to tell what the two compilers
don't
> like about each other?  And second, how does one get eclipse to run
ant
> builds?
>
>  
>
> Thanks
>
> -Mark
>
>  
> This e-mail message, and any attachments, is intended only for the use
of the individual or entity identified in the alias address of this
message and may contain information that is confidential, privileged and
subject to legal restrictions and penalties regarding its unauthorized
disclosure and use. Any unauthorized review, copying, disclosure, use or
distribution is strictly prohibited. If you have received this e-mail
message in error, please notify the sender immediately by reply e-mail
and delete this message, and any attachments, from your system. Thank
you.
>
>   

-- 

... cut twice, paste once.

Shay Thompson - Lead Computer Scientist
Adobe Systems, Inc. - Titan Core QE 
Voice: x34728 or 612.251.5415


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message