ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Scot P. Floess" <>
Subject Re: Weird Deleting Problems..
Date Thu, 14 Sep 2006 13:00:42 GMT

Can you show us your build.xml - or parts of it?

Dan McFadyen wrote:
> Hello,
> I know this is probably going to be a rather odd problem but here goes...
> We have out Build Environment on a network share (Ant, Ant jars, compile
> jars, etc) which just got replaced with a newer machine.
> Since that time the ant scripts have been failing while trying to delete
> local files on the Build machine (the network share is mapped to another
> drive letter on the same machine). The files being deleted are .class files
> that were just compiled, obfuscated and JARed moments before.
> I know this is probably some handle open to the file from ant which is
> causing the delete to fail, and the only immediate difference I can see is
> that the new network share is faster than the old one. I tried sleeping the
> delete to see if that would make a difference, but it had no effect.
> Any ideas on how to solve this are welcome.
> Thanks,
> Dan
> ---------------------------------------------------------------------
> To unsubscribe, e-mail:
> For additional commands, e-mail:

Scot P. Floess
27 Lake Royale
Louisburg, NC  27549

252-478-8087 (Home)
919-754-4592 (Work)

Chief Architect JPlate
Chief Architect JavaPIM

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message