ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Michael Bauroth <michael.baur...@falcom.de>
Subject Re: Replace problem
Date Tue, 12 Sep 2006 09:50:21 GMT
No, & isn't allowed too :(

I've found another solution(!) at all :)

In the build script itself I use an import of an external property file:

<property file="./build/build-tracker.props" />

The property file contains:

encoding = <?xml version="1.0" encoding="ISO-8859-1" ?>

The replace task in the build script looks like this:

<replace file="language.xml" token="@ENCODING@" value='${encoding}' />

Regards
Michael




Mathieu Champlon schrieb:
> Michael Bauroth a écrit :
>> Hi MAT,
>>
>> unfortunately the issue is another one (using Eclipse):
>>
>> <quote>
>> The value of attribute "value" associated with an element type 
>> "replace" must not contain the '<' character.
>> </quote>
> What about :
> <replace file="language.xml" token="@ENCODING" value='&lt;?xml 
> version="1.0" encoding="ISO-8859-1" ?&gt;'/>
> 
> The &gt; is probably not required but it surely does not harm...
> 
> MAT.
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message