ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Keith Hall <keith.h...@granada-learning.com>
Subject Re: Replace problem
Date Tue, 12 Sep 2006 08:41:35 GMT
Have you tried
<replace file="language.xml" token="@ENCODING" value="&lt;?xml
version=&quot;1.0&quot; encoding=&quot;ISO-8859-1&quot; ?&gt;" />

Michael Bauroth wrote:
> Hi MAT,
>
> unfortunately the issue is another one (using Eclipse):
>
> <quote>
> The value of attribute "value" associated with an element type
> "replace" must not contain the '<' character.
> </quote>
>
> Regards
> Michael
>
> Mathieu Champlon schrieb:
>> Michael Bauroth a écrit :
>>> Hi,
>>>
>>> I'm having a little problem with the replace task. Here is the code
>>> snippet:
>>>
>>> <replace file="language.xml" token="@ENCODING" value="<?xml
>>> version="1.0" encoding="ISO-8859-1" ?>" />
>>>
>>> The use of wrapping CDATA doesn't work too.
>>>
>>> Have you eventually any suggestions?
>> Hello,
>>
>> If I understand the issue correctly :
>> <replace file="language.xml" token="@ENCODING" value='<?xml
>> version="1.0" encoding="ISO-8859-1" ?>' />
>> or
>> <replace file="language.xml" token="@ENCODING" value="<?xml
>> version=&quot;1.0&quot; encoding=&quot;ISO-8859-1&quot; ?>" />
>>
>>
>> MAT.
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message