ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <anto...@gmx.de>
Subject Re: Weird Deleting Problems..
Date Thu, 14 Sep 2006 14:28:13 GMT
Hello Dan,

this does sound weird.

are you sure that the ant binaries that you are using now from the new network share are the
same as previously ?

is your java runtime the same as previously ?

Regards,

Antoine

-------- Original-Nachricht --------
Datum: Thu, 14 Sep 2006 09:41:32 -0400
Von: "Dan McFadyen" <danm@cryptocard.com>
An: user@ant.apache.org
Betreff: Weird Deleting Problems..

> Hello,
> 
> I know this is probably going to be a rather odd problem but here goes...
> 
> We have out Build Environment on a network share (Ant, Ant jars, compile
> jars, etc) which just got replaced with a newer machine.
> 
> Since that time the ant scripts have been failing while trying to delete
> local files on the Build machine (the network share is mapped to another
> drive letter on the same machine). The files being deleted are .class
> files
> that were just compiled, obfuscated and JARed moments before.
> 
> I know this is probably some handle open to the file from ant which is
> causing the delete to fail, and the only immediate difference I can see is
> that the new network share is faster than the old one. I tried sleeping
> the
> delete to see if that would make a difference, but it had no effect.
> 
> Any ideas on how to solve this are welcome.
> 
> Thanks,
> 
> Dan
> 

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message