ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <anto...@gmx.de>
Subject Re: Ant Path Problems
Date Fri, 18 Aug 2006 16:02:15 GMT
Maybe the environment variables with which ant gets kicked off by luntbuild are not what you
believe.

You could add something in your build file

<property environment="env"/>
<echo>Path=${env.Path}"
</echo>

In the last Windows OS, the path env var is spelt Path, this is sometimes important to know.

Does luntbuild have a facility to customize the environment variables per build ?

AnthillPro has one, which I am sometimes using.

Regards,

Antoine



-------- Original-Nachricht --------
Datum: Wed, 16 Aug 2006 14:32:28 -0700
Von: "Steve Motola" <SMotola@metadata.com>
An: user@ant.apache.org
Betreff: Ant Path Problems

> One of the difficulties I've always had with Ant is path problems.  I'm
> banging my head over something likely simple and need a leg up.
> 
> Situation:
> 
> Running Luntbuild for Continuos Integration.  Have it checking out a
> master build file from Visual Source Safe.
> 
> This build file in turn calls <vssget> to pull other projects from source
> control and run their build files, etc.
> 
> The error I get is that the 'ss.exe' executable is not being found,
> whereas from the command line this works fine.  The PATH to the executable is
> within the env variables.  There is no <path> or <classpath> params for
> various commands like these - how do I get this to execute properly?

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message