ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Andrew Goktepe" <andrewgokt...@gmail.com>
Subject Re: How to use white spaces in a build script
Date Thu, 27 Jul 2006 16:37:14 GMT
Give an example showing an InfraPath value with spaces, and also show us the
compilation task that is failing, along with the actual error message from
Ant when you run the script. You need to be more specific than "Ant refuses
compilation".

-Andrew

On 7/27/06, Andreas Holtmann <AHoltmann@convivo.de> wrote:
>
> Hi Andrew,
>
> this is in my common.xml:
>
> <property name="CSC.lib-Infragistics" value="${InfraPath}"/>
>
> This is in my net.properties file:
> InfraPath=W:\\\\www\\\\customer.pre\\\\Tmp\\\\Infragistics\\\\Bin
> libs={Standard} {Infragistics}
>
> If there are spaces in the InfraPath (C:\Program Files\blablah), no matter
> how I try to escape them, ANT refuses compilation.
>
> Best,
> Andreas
>
> -----Urspr√ľngliche Nachricht-----
> Von: Andrew Goktepe [mailto:andrewgoktepe@gmail.com]
> Gesendet: Donnerstag, 27. Juli 2006 16:13
> An: Ant Users List
> Betreff: Re: How to use white spaces in a build script
>
> Where is the path being set (property tag, command line, property file,
> etc)? Can you post the relevant parts of your script, and the error that
> you
> get?
>
> -Andrew
>
>
> On 7/27/06, Andreas Holtmann <AHoltmann@convivo.de> wrote:
> >
> > Hi,
> >
> >
> >
> > I have an ANT task which makes use of a DLL that should be copied from a
> > location that contains white spaces in it's path.
> >
> > I did not manage ANT to get rid of the white spaces e.g "C:\Program
> > Files\...". Is there an easy solution? ANT breaks up after the first
> > space.
> >
> >
> >
> > Thanks for your help,
> >
> > Andreas
> >
> >
> >
>

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message