ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jhair Tocancipa Triana <jhair.tocanc...@gmail.com>
Subject Re: SCP Auth Faild
Date Sat, 29 Jul 2006 13:16:06 GMT
I just want to point out, the "Auth fail" error message can be
dependant on the ant version you are running.

E.g. with a production version:

$ ant -version
Apache Ant version 1.6.4 compiled on May 19 2005
$ ant deploy
deploy:
       [cc] Starting dependency analysis for 3 files.
       [cc] 3 files are up to date.
       [cc] 0 files to be recompiled from dependency analysis.
       [cc] 0 total files to be compiled.
      [scp] Connecting to yy.yy.yy.yy:22
BUILD FAILED
build.xml.devel:70: com.jcraft.jsch.JSchException: Auth fail
Total time: 7 seconds

And with a development version:

$ ant -version
Apache Ant version 1.7alpha compiled on July 29 2006
deploy:
       [cc] Starting dependency analysis for 3 files.
       [cc] 3 files are up to date.
       [cc] 0 files to be recompiled from dependency analysis.
       [cc] 0 total files to be compiled.
      [scp] Connecting to yy.yy.yy.yy:22
      [scp] Sending: version.txt : 654
      [scp] File transfer time: 0.12 Average Rate: 5,450.0 B/s
      [scp] done.
BUILD SUCCESSFUL
Total time: 8 seconds

In both cases I use the same jsch-0.1.28.jar and build.xml files.

So the error message can be triggered by an ant bug, which is fixed in
the development version of ant.

-- 
--Jhair

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message