ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominique Devienne" <ddevie...@gmail.com>
Subject Re: ANT script fails to run when path contains '!'
Date Tue, 11 Jul 2006 12:32:46 GMT
The escape char for bat (cmd) is ^ but it's far from certain it will
solve your issue. --DD

On 7/11/06, madhuvanti joshi <j_madhuvanti@yahoo.com> wrote:
> Keith,
>
> I checked this, but it might not be the case as ! is
> not followed by \ as specified in the link you have
> given below and it is not used in java prog, it is
> used in batch file which calls ANT script.
>
> Could anybody pls tell me which escape characher could
> be used for ! in command below:(I've tried a lot like
> '/' or &#33 but couldn't find it) so that path is
> found
>
> java -classpath %CP% org.apache.tools.ant.Main
> -buildfile "C:\Program Files\Some!Path\AntMainDir"
>
>
> --- Keith Hatton <khatton@axiomsystems.com> wrote:
>
> > This could be because the ! character indicates a
> > resource within a JAR
> > file.
> > (see
> >
> http://java.sun.com/j2se/1.5.0/docs/api/java/net/JarURLConnection.html)
> >
> > Hope this helps
> > Keith
> >
> >
> >
> > -----Original Message-----
> > From: madhuvanti joshi
> > [mailto:j_madhuvanti@yahoo.com]
> > Sent: 10 July 2006 06:20
> > To: Ant Users List
> > Subject: ANT script fails to run when path contains
> > '!'
> >
> >
> > Hi All,
> >
> > I have a batch file through which I am calling ANT
> > script. Before calling ANT script, I am setting
> > CLASSPATH through batch file to the path containing
> > ANT libraries and product.
> >
> > Although CLASSPATH has been set properly when I have
> > a
> > '!' in the path ( e.g. C:\Program
> > Files\Some!Path\AntMainDir), ANT script fails with
> > return code 3 (on windows - path not found) with
> > build exception "Can't
> > load default task list". (It does not find
> > org/apache/tools/ant/taskdefs/defaults.properties)
> >
> > I want to know why it is not finding the path when
> > it
> > contains '!'? (If I remove'!' from Some!Path then
> > everything works fine.)
> >
> > Thanks in Advance.
> >
> > -Madhu.
> >
> >
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam
> > protection around
> > http://mail.yahoo.com
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> > user-unsubscribe@ant.apache.org
> > For additional commands, e-mail:
> > user-help@ant.apache.org
> >
> >
> >
> ---------------------------------------------------------------------
> > To unsubscribe, e-mail:
> > user-unsubscribe@ant.apache.org
> > For additional commands, e-mail:
> > user-help@ant.apache.org
> >
> >
>
>
> __________________________________________________
> Do You Yahoo!?
> Tired of spam?  Yahoo! Mail has the best spam protection around
> http://mail.yahoo.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message