ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anderson, Rob (Global Trade)" <Rob.Ander...@nike.com>
Subject RE: Running web logic server in Ant 1.6.5
Date Mon, 24 Jul 2006 17:44:08 GMT
It looks like the jdk 1.3.1 version you are using is not compatible with
the version of GLIBC 2.0. BEA should be able to tell you what version of
jdk you need to run Weblogic. It's been a while since I used Weblogic,
but doesn't it come with a jdk? If so, use the one provided. The error
you get while using jdk 1.4 indicates that the build failed while trying
to run the wlrun task. The line number specified only indicates the last
line of the task Ant was trying to run when it failed. It really does
not mean that your problem is necessarily on that line. Run Ant again
with -verbose option and send the full output.

-Rob Anderson

> -----Original Message-----
> From: Nooreazam [mailto:nooreazamp@tarangtech.com] 
> Sent: Monday, July 24, 2006 7:34 AM
> To: user@ant.apache.org
> Subject: Running web logic server in Ant 1.6.5
> 
> 
> Hi,
> 
> Iam using the following code to run the web logic server using ant.
> 
> <wlrun beahome="${BEA_HOME}"
> home="${WL_HOME}"
> domain="${WL_MPURSE_DOMAIN}"
> name="${WL_MPURSE_SERVER}"
> policy="${WL_HOME}/server/lib/weblogic.policy"
> password="${WL_PASSWORD}"
> jvmargs="-server -Xincgc -Xms256m -Xmx256m 
> -Dweblogic.ProductionModeEnabled=${WL_STARTMODE}"
> >
> <classpath>
> <pathelement location="${FWRK_HOME}/config" /> <fileset 
> dir="${FWRK_HOME}/3rdparty/jars"> <include name="*.jar"/> 
> <include name="*.zip"/> </fileset> <pathelement 
> location="${WL_HOME}/server/lib/weblogic.jar" /> <fileset 
> dir="${WL_HOME}/config/${WL_MPURSE_DOMAIN}/lib">
> <include name="*.jar"/>
> </fileset>
> </classpath>
> </wlrun>
> 
> Following are the versions --
> Weblogic 7.0
> J2sdk 1.3.1_06
> Ant 1.6.5
> os is linux-- Fedora.
> 
> When i run this one it is giving me the following error --
> 
> 
> Error occurred during initialization of VM Unable to load 
> native library:
> /home/nooreazamp/tools/CVS/BKP_Weblogic_TPS/bea/jdk1.3.1_06/jr
> e/lib/i386/libjava.so:
> symbol __libc_wait, version GLIBC_2.0 not defined in file 
> libc.so.6 with link time reference
> 
> When i use J2sdk 1.4, its giving --
> Execution of weblogic server failed at line 67..
> Following is the 67th line
> jvmargs="-server -Xincgc -Xms256m -Xmx256m 
> -Dweblogic.ProductionModeEnabled=${WL_STARTMODE}".
> 
> Pls can any body tell, what is wrong here. Its urgent..
> 
> Regards,
> Noor.
> --
> View this message in context: 
> http://www.nabble.com/Running-web-logic-server-in-Ant-1.6.5-tf
> 1992698.html#a5468593
> Sent from the Ant - Users forum at Nabble.com.
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message