ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Carpentier, Nelson" <NCarpent...@icat.com>
Subject <junitreport> and Weblogic
Date Tue, 13 Jun 2006 20:15:04 GMT
Hi All,

I've signed on to bring a solution.

I've been dealing with the following error message for quite some time
when running <junitreport>:
D:\somedir\build.xml:206: Could not find a valid processor version
implementation from weblogic.xml.jaxp.RegistrySAXTransformerFactory

This happens because Weblogic (in their infinite wisdom) need to have
their own weblogic.jar/webservices.jar files polluting the ANT\lib, if
you're gonna use some of their ANT tasks during your build process.
(Believe me, I've got a ticket or three wranglin' with them about
this...)

If you can take the Weblogic JARs out of the ANT\lib, then great!  I
wholly suggest you do it...

But for those of us who cannot do that (specifically in my case because
I am using their <servicegen> task in 8.1SP5), the solution is to
further add other things to your ANT\lib directory.  I not only had to
add the xalan-2.4.1.jar file, but I had to rename it to
"antx-xalan-2.4.1.jar" so that it would end up in the classpath before
the weblogic pollutions.  

Now, I am able to run the <junitreport>...  And, I haven't had it create
any other problems for me yet...  (But, oh! How I long for a nice, clean
ANT\lib...)

Good luck!!

- Nelz

Mime
  • Unnamed multipart/alternative (inline, 7-Bit, 0 bytes)
View raw message