ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "jason suplizio" <supli...@hotmail.com>
Subject RE: calling maven2 files from ant
Date Wed, 07 Jun 2006 15:52:41 GMT
I'm not on this list. I've unsubscribed 3 times already in the past 2 weeks. 
Anyone have a clue wtf is up?


From: "EJ Ciramella" <ejciramella@upromise.com>
Reply-To: "Ant Users List" <user@ant.apache.org>
To: "Ant Users List" <user@ant.apache.org>
Subject: RE: calling maven2 files from ant
Date: Tue, 6 Jun 2006 09:59:02 -0400

I've used the scripts talked about in the three postings (and it's
similar to what we're doing - a bat file eventually calls a shell
script, etc).  But it still hangs.  Everything is being redirected
properly.

-----Original Message-----
From: Master, Tariq (Abbeywood) [mailto:Tariq.Master@uk.bp.com]
Sent: Tuesday, June 06, 2006 9:53 AM
To: Ant Users List
Subject: RE: calling maven2 files from ant

Steve,

It's where CruiseControl hangs by waiting for the CMD shell window to be
closed.  It's basically waiting for any forked exec call in Ant to
finish/close as far as I can gather.  Everything works fine using Ant.
But it's when a process (CC or cygwin apparantly) calls ant that
problems occur.


More information:

[1] http://sourceforge.net/mailarchive/message.php?msg_id=13111442

[2]
http://confluence.public.thoughtworks.org/display/CC/StartingAnAsynchron
ousProcessFromExecTask

[3]
http://confluence.public.thoughtworks.org/display/CC/Starting+a+server+w
ith+cc


My email to the Cruise mailing list:
--
From: cruisecontrol-user-bounces@lists.sourceforge.net
[mailto:cruisecontrol-user-bounces@lists.sourceforge.net] On Behalf Of
Master, Tariq (Abbeywood)
Sent: 26 May 2006 18:47
To: cruisecontrol-user@lists.sourceforge.net
Subject: [Cruisecontrol-user] Hang after build successful due to a
forkedcmd.exe window open



My cruise (2.4.1) calls my ant (1.6.5) scripts on WinXP.  My ant script
has a target to start up weblogic using the <exec> spawned ant task.
After my tests run, it shuts down weblogic using the <java> forked
command.

These work fine as part of a full ant build.

However, when cruise runs, it will hang after the "BUILD SUCCESSFUL
Total time: 1 minute 19 seconds" message, UNTIL the weblogic cmd window
is closed.

Once I manually close the window, my cruise debug session immediately
dumps/outputs to the console, lots of:
         [cc]May-26 18:38:16 yElementFilter- Skipping empty <task>-tag
...followed by the build result event success message.

Does anyone know what causes cruise to hang?  How does it detect a
console window open (it was created in a forked process)?  How to
resolve?


Any suggestions or tips appreciated.





-----Original Message-----
From: Steve Loughran [mailto:stevel@apache.org]
Sent: 06 June 2006 14:39
To: Ant Users List
Subject: Re: calling maven2 files from ant

EJ Ciramella wrote:
 > Considering that everything will ultimately be used via CruiseControl
AND how little success I've had with the exec task and CC, I was hoping
for some optional tasks.
 >

I've never encountered problems with CC and exec. what kind of problems?

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org For additional
commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message