ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jan Ploski <>
Subject Re: Ant can't find the Apache resolver library
Date Sat, 03 Jun 2006 18:34:11 GMT
CĂ©lio Cidral Junior wrote on Thu, 06 Apr 2006 19:48:23 GMT:
> I'm trying to run a build script which has a target that uses the
> <style> task and references an external <xmlcatalog>, but Ant is
> giving me the warning message below.
>    Apache resolver library not found, internal resolver will be used
>    Warning: catalogpath listing external catalogs will be ignored
> I've Googled a lot about this problem and couldn't find any helpful
> information, except this thread:


I got the same error message today and solved it. So I am posting
some comments on this issue for the archive:

The original author's problem has been probably caused by the fact that
he was using xml-commons-resolver-1.0 in the classpath. The Ant
documentation explicitly mentions that you should use

My own problem was caused by myself having put the correct version
of resolver.jar into JDK's jre/lib/endorsed directory (because I upgraded
Xalan and it appeared to pick it up all right from there). For some reason,
if resolver.jar is visible to the classloader for jre/lib/endorsed, Ant
will not be able to use it, EVEN if you add it to the Ant classpath.

Jan Ploski

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message