ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Antoine Levy-Lambert" <anto...@gmx.de>
Subject Re: RE: RE: rexec hangs
Date Wed, 21 Jun 2006 19:09:19 GMT
Hello,

I think that the rexec functionality in ant is delivered by commons-net. Which version of
commons-net were you using ?

Also, if your custom client works, then there is a bug in ant or a bug in commons-net.

Regards,

Antoine
-------- Original-Nachricht --------
Datum: Wed, 21 Jun 2006 13:48:03 -0400
Von: "Lu, Tao (MTO)" <Tao.Lu@mto.gov.on.ca>
An: \'Ant Users List\' <user@ant.apache.org>
Betreff: RE: RE: rexec hangs

> I used the default value for timeout which is "no timeout". Also I tried
> to
> set it to "5 secs", I got the same result. 
> 
> Anyways, I just wrote my own REXEC client(Java), and wrapped it as custom
> Ant task, everything is working fine. 
> 
> Cheers,
> Tao
> 
> 
> -----Original Message-----
> From: Martin Gainty [mailto:mgainty@hotmail.com]
> Sent: June 21, 2006 12:49 PM
> To: Ant Users List
> Subject: Re: RE: rexec hangs
> 
> 
> Bonjour/Hello-
> 
> My first instinct was to say set fork="true" but that options doesnt exist
> ..at least not yet!
> What is your <rexec timeout parameter set to ??
> 
> Merci/Thanks,
> Martin --
> *********************************************************************
> This email message and any files transmitted with it contain confidential
> information intended only for the person(s) to whom this email message is
> addressed.  If you have received this email message in error, please
> notify
> the sender immediately by telephone or email and destroy the original
> message without making a copy.  Thank you.
> 
> 
> 
> ----- Original Message ----- 
> From: "Lu, Tao (MTO)" <Tao.Lu@mto.gov.on.ca>
> To: "'Ant Users List'" <user@ant.apache.org>
> Sent: Wednesday, June 21, 2006 10:26 AMWhats t
> Subject: RE: RE: rexec hangs
> 
> 
> > Sorry for the confusion. The actually ant task I was trying to execute
> is 
> > <rexec userid="<some user>" password="<password>" server="42.142.125.60"
> > command="ls"/>
> > I mistakenly place "localhost" in my previous email. 
> > 
> > Any clue?
> > Thanks in advance!
> > 
> > Tao
> > 
> > 
> > 
> > -----Original Message-----
> > From: Petar Tahchiev [mailto:paranoiabla@gmail.com]
> > Sent: June 21, 2006 5:50 AM
> > To: Ant Users List
> > Subject: Re: RE: rexec hangs
> > 
> > 
> > On 20/06/06, Lu, Tao (MTO) <Tao.Lu@mto.gov.on.ca> wrote:
> >> In command prompt, I issued "telnet 142.142.125.60 512", no error
> > messages,
> >> I got a blank DOS screen. I believe port 512 is already open.
> >>
> > 
> >> Btw, if I run this locally
> >> C:\>rexec 142.142.125.60 -l bob ls -l
> >> It works fine.
> >>
> >> Thanks
> >> Tao
> >>
> >>
> >> -----Original Message-----
> >> From: Antoine Levy-Lambert [mailto:antoine@gmx.de]
> >> Sent: June 20, 2006 6:45 PM
> >> To: Ant Users List
> >> Subject: Re: RE: rexec hangs
> >>
> >>
> >> Hello Lu,
> >>
> >> open a command prompt, then try this command :
> >>
> >> telnet localhost 512
> >>
> >> if rexec is disabled on your computer, you will see this message :
> >>
> >> Connecting To localhost...Could not open connection to the host, on
> port
> >> 512: Co
> >> nnect failed
> >>
> >> (this is what I see on my Windows box).
> >>
> >>
> >> Regards,
> >>
> >> Antoine
> >>
> >>
> >> -------- Original-Nachricht --------
> >> Datum: Tue, 20 Jun 2006 18:30:20 -0400
> >> Von: "Lu, Tao (MTO)" <Tao.Lu@mto.gov.on.ca>
> >> An: \'Ant Users List\' <user@ant.apache.org>
> >> Betreff: RE: rexec hangs
> >>
> >> > I tried, but the same thing.
> >> > Is there any setting required on remote server side?
> >> >
> >> > Thanks
> >> > Tao
> >> >
> >> >
> >> > -----Original Message-----
> >> > From: kindsol [mailto:kindsol@hotpop.com]
> >> > Sent: June 20, 2006 6:28 PM
> >> > To: Ant Users List
> >> > Subject: Re: rexec hangs
> >> >
> >> >
> >> > did you run ant in verbose mode?
> >> >
> >> > ant -v
> >> >
> >> > And still nothing?
> >> >
> >> > On Jun 20, 2006, at 3:17 PM, Lu, Tao (MTO) wrote:
> >> >
> >> > > Hi, All,
> >> > > I tried to test <rexec> task to execute some simple command
on a
> >> > > remote
> >> > > Solaris box. Here is my task.
> >> > >     <rexec userid="bob" password="pass" server="localhost"
> >> > > command="ls"/>
> >> > > But it hangs, by hang, I mean the ant doesn't produce any output.
> >> > > The version I am using is ant 1.6.5
> >> > > Any clue?
> >> > >
> >> > > Thanks a lot!
> >> > > Tao
> >> > >
> >> > >>  -----Original Message-----
> >> > >> From:      Lu, Tao (MTO)
> >> > >> Sent:      June 20, 2006 5:57 PM
> >> > >> To:        'user@ant.apache.org'
> >> > >> Subject:   rexec hangs
> >> > >>
> >> > >> Hi, All,
> >> > >>
> >> > >> <rexec userid="bob" password="pass" server="localhost"
> command="ls"/>
> >> > >>
> >> > >> Why it hangs?
> >> > >>
> >> > >> ant 1.6.5
> >> > >>
> >> > >> Thanks
> >> > >> Tao
> >> > >
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> >> For additional commands, e-mail: user-help@ant.apache.org
> >>
> >> ---------------------------------------------------------------------
> >> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> >> For additional commands, e-mail: user-help@ant.apache.org
> >>
> >>
> > I have a question.
> > 
> > In your ant task you try to rexec to the localhost.
> > 
> > And later you "telnet" to "142.142.125.60 512", why is this?
> > If the server you are trying to exec is 42.142.125.60 512 then change
> > your ant task.
> > 
> > And if you try to exec something on the localhost then check to ensure
> > localhost is properly configured in your /etc/hosts file.
> > 
> > -- 
> > Regards, Petar!
> > Karlovo, Bulgaria.
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> > For additional commands, e-mail: user-help@ant.apache.org
> > 
> > ---------------------------------------------------------------------
> > To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> > For additional commands, e-mail: user-help@ant.apache.org
> > 
> >
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message