ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Guttula, Mohan" <MGutt...@tiaa-cref.org>
Subject "dest" attribute of apply task is not working as expected?
Date Mon, 05 Jun 2006 20:25:33 GMT
Hello All,

I'm using "apply" task to compile my actuate reports using the following
target:
-----
<target name="compile">
	<!-- Compile Actuate reports -->  
	<condition property="erdpro.client.dir" value="C:\Program
Files\Actuate8\eRDPro\bin" >
		<os family="windows"/>
	</condition>       
	<apply executable="${erdpro.client.dir}/erdpro"
dest="c:\temp\destination" output="actuate.log" parallel="true">
		<arg value="-b"/>
		<fileset dir="c:\temp\source">
			<patternset>
				<include name="*.rod"/>
			</patternset>
		</fileset>
		<mapper type="glob" from="*.rod" to="*.rox"/>
	</apply>
</target>
------

I was expecting the compiled reports to go into directory
"c:\temp\destination" as per the "dest" attribute of apply task. But the
compiled files are created in "c:\temp\source" (i.e., source directory
that contains the designed reports --- "dir" attribute of "fileset")

Could some please let me know if you ran into this issue or where I'm
making a mistake?

Thanks,
Mohan


**************************************************************
This message, including any attachments, contains confidential information intended for a
specific individual and purpose, and is protected by law.  If you are not the intended recipient,
please contact sender immediately by reply e-mail and destroy all copies.  You are hereby
notified that any disclosure, copying, or distribution of this message, or the taking of any
action based on it, is strictly prohibited.
TIAA-CREF
**************************************************************


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message