ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "shree vinayakh" <bvinay...@gmail.com>
Subject Re: Fw: Ant mail problem SMTPSendFailedException Client was not authenticated
Date Wed, 10 May 2006 04:38:18 GMT
hi,

<project name="testing" basedir="." default="greatest">
<target name="sendmail" depends="doSomethingElse">
<mail mailhost="antivirus.fr.clara.net" mailport="25" subject="Test build"
charset="utf-8" user="bvinayakh@adaptime.net" password="welcome" files="
sample.txt">
<from address="bvinayakh@adaptime.net"/>
<replyto address="bvinayakh@adaptime.net"/>
<to address="bvinayakh@adaptime.net"/>
<message>Test Mail</message>
</mail>
</target>

the above is my ant task and it works well with the attachment too...

i got the same problem with the mime types. i added pop3.jar, smtp.jar,
mail.jar, mailapi.jar and activation.jar.
once this is done i was able to send emails without any problem using my ant
task.

regards,

shreevinayakh

On 5/9/06, Devaraj, Geethakrishnan <geethakrishnan@ncmr.co.in> wrote:
>
>
> Hi All,
>
> Could u help me with this problem.I am using Ant 1.6.2 to send a mail i
> have downloaded mail.jar and aactivation.jar and put it in my
> ANT_HOME/lib.My ant task looks as below.
>
> <target name="mail">
>      <mail mailhost="mail.ncmr.co.in" mailport="25" subject="test"
> user="geethakrishnan" password="bottleneck">
>       <from address="geethakrishnan@ncmr.co.in" />
>       <replyto address="geethakrishnan@ncmr.co.in" />
>       <to address="sivakumar@ncmr.co.in" />
>       <message>TEST MAIL FROM ANT</message>
>      </mail>
>     </target>
>
> when i try to run ant -debug mail i get the following error
>
> D:\krishna\27-03-2006-Sprint2\productcreator\tool\build.xml:681: Problem
> while s
> ending mime mail:
>         at org.apache.tools.ant.taskdefs.email.MimeMailer.send(
> MimeMailer.java:2
> 29)
>         at org.apache.tools.ant.taskdefs.email.EmailTask.execute(
> EmailTask.java:
> 548)
>         at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java
> :275)
>         at org.apache.tools.ant.Task.perform(Task.java:364)
>         at org.apache.tools.ant.Target.execute(Target.java:341)
>         at org.apache.tools.ant.Target.performTasks(Target.java:369)
>         at org.apache.tools.ant.Project.executeTarget(Project.java:1214)
>         at org.apache.tools.ant.Project.executeTargets(Project.java:1062)
>         at org.apache.tools.ant.Main.runBuild(Main.java:673)
>         at org.apache.tools.ant.Main.startAnt(Main.java:188)
>         at org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)
>         at org.apache.tools.ant.launch.Launcher.main(Launcher.java:55)
> Caused by: com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.3 Client was
> not a
> uthenticated
>
>         at com.sun.mail.smtp.SMTPTransport.issueSendCommand(
> SMTPTransport.java:1
> 388)
>         at com.sun.mail.smtp.SMTPTransport.mailFrom(SMTPTransport.java
> :959)
>         at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java
> :583)
>         at javax.mail.Transport.send0(Transport.java:169)
>         at javax.mail.Transport.send(Transport.java:98)
>         at org.apache.tools.ant.taskdefs.email.MimeMailer.send(
> MimeMailer.java:2
> 27)
>         ... 11 more
> --- Nested Exception ---
> com.sun.mail.smtp.SMTPSendFailedException: 530 5.7.3 Client was not
> authenticate
> d
>
>         at com.sun.mail.smtp.SMTPTransport.issueSendCommand(
> SMTPTransport.java:1
> 388)
>         at com.sun.mail.smtp.SMTPTransport.mailFrom(SMTPTransport.java
> :959)
>         at com.sun.mail.smtp.SMTPTransport.sendMessage(SMTPTransport.java
> :583)
>         at javax.mail.Transport.send0(Transport.java:169)
>         at javax.mail.Transport.send(Transport.java:98)
>         at org.apache.tools.ant.taskdefs.email.MimeMailer.send(
> MimeMailer.java:2
> 27)
>         at org.apache.tools.ant.taskdefs.email.EmailTask.execute(
> EmailTask.java:
> 548)
>         at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java
> :275)
>         at org.apache.tools.ant.Task.perform(Task.java:364)
>         at org.apache.tools.ant.Target.execute(Target.java:341)
>         at org.apache.tools.ant.Target.performTasks(Target.java:369)
>         at org.apache.tools.ant.Project.executeTarget(Project.java:1214)
>         at org.apache.tools.ant.Project.executeTargets(Project.java:1062)
>         at org.apache.tools.ant.Main.runBuild(Main.java:673)
>         at org.apache.tools.ant.Main.startAnt(Main.java:188)
>         at org.apache.tools.ant.launch.Launcher.run(Launcher.java:196)
>         at org.apache.tools.ant.launch.Launcher.main(Launcher.java:55)
>
> i have also tried to ping and it works...telnet host 25 is also fine..
>
> any solutions
>
> Regards,
> Geethakrishnan
>



--
shreevinayakh
Software Engineer,
Adaptime Infotech India Pvt. Ltd.

Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message