ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barak Yaish" <>
Subject RE: rmic problem when using ant
Date Tue, 30 May 2006 10:59:53 GMT
Exactly. When running ant twice with the same build.xml, first run fails with the error I mentioned
below, running it again, and... no failures...

Can you direct me what I'm doing wrong? Why the second run doesn't fail?



-----Original Message-----
From: Scot P. Floess []
Sent: ?? 30 ??? 2006 13:49?
To: Ant Users List
Subject: Re: rmic problem when using ant


Sounds like a CLASSPATH problem...  Or sourcepath?

So, if you run your build twice it works?

Barak Yaish wrote:
> Hi all,
> I'm facing strange problem when I'm using the RMIC task. First, let me describe the relevant
> Class A extends UnicastRemoteObject implements AInterface
> Interface AInterface implements Remote
> Class B extends A implements BInterface
> Interface BInterface extends AInterface
> The methods in class A defined as throwing SomeException  (beside RemoteException), found
in 3rd party jar.
> The sequence in build.xml is: compile A, rmic A, compile B, rmic B
> Now, compile and rmic A is working ok. Compiling B is working ok. Rmic of b not working
- the message displayed is:
> [rmic] error: Class SomeException not found in class A. (this is not mistake - why A
appears here?)
> 1) What this message means?
> The strange part, when I re-running ant with the same build.xml everything is working
fine, include the rmic of B.
> 2) What am I doing wrong?
> Thanks,
> Barak.

Scot P. Floess
27 Lake Royale
Louisburg, NC  27549

252-478-8087 (Home)
919-754-4592 (Work)

Chief Architect JPlate
Chief Architect JavaPIM

To unsubscribe, e-mail:
For additional commands, e-mail:

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message