ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Asaf Mesika <asaf.mes...@gmail.com>
Subject RE: ftp task fails when file has ' (apostrophe symbol)
Date Mon, 22 May 2006 16:36:20 GMT
Have you tried viewing the source code for the ftp get task? This might give
you the answer.


> -----Original Message-----
> From: David [mailto:achepati67@yahoo.es]
> Sent: Monday, May 22, 2006 5:19 PM
> To: Ant Apache User Group
> Subject: ftp task fails when file has ' (apostrophe symbol)
> 
> 
> I have to get a file from the server, but the name has to be encloses by '
> symbol, for example: 'foo.txt', but Ant process the file name an
> eliminates the   delimitors. I have tested the ftp action with a file
> without ' on its name and   it works.    It is a problem with the ftp task
> and not with the fileSet definition, I guess   because I have tried to use
> the '-symbol on the name for making a copy of the   file and it works (see
> below)    I am sending to you a piece of code in orde to see more clear:
> <target name="get-input-files"          description="Get the input files
> from the LRA production machine"          depends="get-current-time"
> >          <echo level="verbose"            message= "Getting file:
> '${holder.prefix}${current.time}' from   server: ${server}"/>
> <copy file="'borrame.txt'" tofile="'nuevo_borrame.txt'"/>          <ftp
> action="get"              server="${server}"
> userid="${login}"
>  password="${password}"              verbose="yes"              binary =
> "false"              >              <fileset dir=".">
> <include name="BORRAME.TXT"/>                <include
> name="'PRVL.JSCHIT.L3BSCHI2.SALIDA.NNBAA.D060404'"/>
> </fileset>              <!--fileset
> file="'${holder.prefix}${current.time}'"/-->          </ftp>
> </target>  and I get the following output in debug mode:    get-input-
> files:       [echo] Getting file:
> 'PRVL.JSCHIT.L3BSCHI2.SALIDA.NNBAA.D060404' from   server: aris.bsch
> [copy] P:\LRA\src\resource\'borrame.txt' omitted as
> P:\LRA\src\resource\'nuevo_borrame.txt' is up to date.        [ftp]
> Opening FTP connection to aris.bsch        [ftp] connected        [ftp]
> logging in to FTP server        [ftp] login succeeded        [ftp] getting
> files  Could not load a dependent class
> (com/sun/media/jai/codec/FileSeekableStream)   for type image  Could not
> load a dependent class (com/jcraft/jsch/UserInfo) for type
>  sshexec  Could not load a dependent class (com/jcraft/jsch/UserInfo) for
> type scp  Could not load a dependent class (jdepend/xmlui/JDepend) for
> type jdepend  fileset: Setup scanner in dir P:\LRA\src\resource with
> patternSet{ includes:   [BORRAME.TXT,
> PRVL.JSCHIT.L3BSCHI2.SALIDA.NNBAA.D060404] excludes: [] }  filelist map
> used in listing files  filelist map used in listing files  filelist map
> used in listing files        [ftp] transferring BORRAME.TXT to
> P:\LRA\src\resource\BORRAME.TXT        [ftp] File
> P:\LRA\src\resource\BORRAME.TXT copied from aris.bsch        [ftp] 1 files
> retrieved        [ftp] disconnecting    BUILD SUCCESSFUL      as you can
> see the file name is changed for the ftp task but not for the copy   task.
> WHY????    Please let me know if the is any shortcut solution for this
> problem in the mean   time you solve it for the next release.    Thanks,
> David
> 
> P.D.: I have reported this possible bug on:
> 
> http://issues.apache.org/bugzilla/show_bug.cgi?id=39204
> 
> 
> ---------------------------------
> Love cheap thrills? Enjoy PC-to-Phone  calls to 30+ countries for just
> 2ยข/min with Yahoo! Messenger with Voice.


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message