ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From john does <baywatch312...@yahoo.com>
Subject ant cvs checkout doesn't work
Date Fri, 05 May 2006 12:44:01 GMT
Hi,
   
  I have a problem with cvs from Ant.
Connecting to cvs directly from the commandline works as expected.

When I attempt the same cvs incantation running the cvs task from Ant it 
just seems to hang. 
   
  I have following error :
  ----
  cvs exited with error code -1
Command line was [Executing 'cvs' with arguments:
'-d:pserver:user@cvs-sandbox.org.net:/var/data/cvs/cvs-sandbox'
'checkout'
'project'
  The ' characters around the executable and arguments are
not part of the command.
-----
  in my build.xml file, I have :
  <property name="cvsroot"
               value=":pserver:user@cvs-sandbox.org.net:/var/data/cvs/cvs-sandbox"/>
<property name="pass" value="user" />

      <target name="cvsLogin">
       <cvspass cvsroot="${cvsroot}" password="${pass}"/>
    </target>
      <target name="cvsCheck" depends="cvsLogin" >
      <cvs cvsRoot="${cvsroot}" command="checkout" package="project" dest="/home/user"
         failonerror="true"/>
      </target>

   
  Have you an idea?
   
  Any help appreciated
  thanks
   
  Chris


__________________________________________________
Do You Yahoo!?
Tired of spam?  Yahoo! Mail has the best spam protection around 
http://mail.yahoo.com 
Mime
  • Unnamed multipart/alternative (inline, 8-Bit, 0 bytes)
View raw message