ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jeffrey E Care <ca...@us.ibm.com>
Subject Re: Property problem in 1.6.5
Date Fri, 07 Apr 2006 02:58:02 GMT
This is working as designed; ant, antcall & subant create new contexts and 
property values set in the context ARE NOT propegated back to the calling 
context.

____________________________________________________________________________________________


Jeffrey E. (Jeff) Care 
carej@us.ibm.com 
IBM WebSphere Application Server Development 
WAS Pyxis Lead Release Engineer 




"Greg Irvine" <greg.irvine@thalesatm.com> wrote on 04/06/2006 07:11:14 PM:

> Hi all.
> 
> I'm having a problem with property values not existing outside of the 
target
> they're created/set in.
> 
> For example (see below), I have a "jar" target that calls an "update"
> target.  The update calls svn status to populate a property with the 
current
> svn version number and then I echo the property.  Control then returns 
to
> "jar" where I attempt to echo the property again.
> The property echoes correctly within the "update" target (e.g.) "11134", 
but
> displays as "${repository.revision} in the "jar" echo.
> 
> Any ideas?
> 
> Please CC me in the response for faster delivery.
> 
> Thanks and regards,
> 
> Greg.
> 
> 
> 
> <target name="jar">
>     <antcall target="update>
>     <echo>REVISION=${ repository.revision }</echo> 
> </target>
> 
> <target name="update">
>     <svn>
>         <status path="." revisionProperty="repository.revision"/>
>     </svn>
>     <echo>REVISION=${ repository.revision }</echo>
> </target>
> 
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 

Mime
  • Unnamed multipart/related (inline, None, 0 bytes)
View raw message