ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Steve Loughran <ste...@apache.org>
Subject Re: Script task not found
Date Mon, 24 Apr 2006 16:31:46 GMT
Paul Donaldson wrote:
> Antoine/Peter - thank you for your replies.
> 
> I'm using Ant version 1.5.1.
> 
> I realise that is reasonably old. I've also noted that, with that version of
> Ant, I should be using IBM's BSF rather than Apache's. However, I cannot
> find an INM version of bsf.jar anywhere. Any links I have found, that report
> to have it, in fact do not.
> 
> ** But regardless of that **, I do not seem to be getting as far as the bsf
> version issue. Ant is telling me it can't even find Script.class - but it's
> right there in optional.jar - which is in the lib folder!
> 
> Is it perhaps the case that if the classloader cannot find a class that
> Script.class relies on (a BSF one say) then I will get the message I am
> seeing, i.e. that Script.class cannot be found (when in fact it can, but a
> class it references can't be found)?

Ant1.7 will have much better diagnostics messages, which will help with 
this problem. For ant<=1.6 it
doesnt explore why it couldnt instantiate a class.

> 
> I need a solution that works on Ant version 1.5.1 and 1.6.1 (the same build
> scripts are run on machines with Ant 1.5.1 and on machines with Ant 1.6.1).

I dont think you have that option. Is there any reason for not upgrading 
the 1.5.x boxes?




---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message