ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <anto...@gmx.de>
Subject Re: can't compile ant
Date Tue, 11 Apr 2006 13:43:37 GMT
Michael Perkonigg wrote:
> Hello,
>
> I'm trying to install ant from source and if I call build.sh it alwas
> gives me errors from the optional tasks.
> I thought that optional tasks aren't compiled if there are missing
> dependencies?
> I tried to install the jakarta-oro-2.0.8.jar file (which contains the
> Perl5Util class) into the lib directory but it didn't change anything.
>
Hello Michael,

Dependencies needed at build time should be put under lib/optional, not
under lib.

It sounds like this is not really documented ... not sure.

I built myself the 1.6.x versions of ant and I used jakarta-oro-2-0-8.

Regards,

Antoine

> Thanks,
> Mike
>
>
> The output:
>
>
> build:
> Created dir: /home/mipe/svntest/ant2/apache-ant-1.6.5/build/lib
> Compiling 243 source files to
> /home/mipe/svntest/ant2/apache-ant-1.6.5/build/classes
> /home/mipe/svntest/ant2/apache-ant-1.6.5/src/main/org/apache/tools/ant/taskdefs/optional/perforce/FStatP4OutputHandler.java:20:
> package org.apache.oro.text.perl does not exist
> import org.apache.oro.text.perl.Perl5Util;
>                                ^


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message