ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominique Devienne" <ddevie...@gmail.com>
Subject Re: Is there an ant version that supports JavaCC 4.0?
Date Tue, 04 Apr 2006 13:11:22 GMT
> To build my code in Java 5, it's required to upgrade JavaCC to
> version 4.0.  I have downloaded JavaCC source and built the JavaCC.zip file.
> I'm having problem when executing javacc from ant build.xml file. ant
> is looking for "COM.sun.labs..." when the source that I have built
> contains "org.javacc" package name.

Have you check whether JavaCC 4 itself provides an Ant task? More and
more external tools like JavaCC are encouraged to develop (and
support!) their own tasks, since 1) Ant's API is stable, 2) it allows
these tasks to evolve when the tool is released rather than when Ant
is released.

I'd encourage you to ask the JavaCC community about Ant support.
Sorry, not an answer to your question ;-) --DD

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message