ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Greg Irvine" <greg.irv...@thalesatm.com>
Subject RE: Property problem in 1.6.5
Date Thu, 06 Apr 2006 23:17:29 GMT
Ok.  I've progressed slightly on this.  It seems a property set in one
target isn't returned to the calling target, however, if I call the targets
separately, it works.
e.g.  "ant update jar",   rather than "ant jar" and have jar call update.

Hmm...  


-----Original Message-----
From: Greg Irvine [mailto:greg.irvine@thalesatm.com] 
Sent: Friday, 7 April 2006 9:11 AM
To: 'Ant Users List'
Subject: Property problem in 1.6.5

Hi all.

I'm having a problem with property values not existing outside of the target
they're created/set in.

For example (see below), I have a "jar" target that calls an "update"
target.  The update calls svn status to populate a property with the current
svn version number and then I echo the property.  Control then returns to
"jar" where I attempt to echo the property again.
The property echoes correctly within the "update" target (e.g.) "11134", but
displays as "${repository.revision} in the "jar" echo.

Any ideas?

Please CC me in the response for faster delivery.

Thanks and regards,

Greg.



<target name="jar">
    <antcall target="update>
    <echo>REVISION=${ repository.revision }</echo> 
</target>

<target name="update">
    <svn>
        <status path="." revisionProperty="repository.revision"/>
    </svn>
    <echo>REVISION=${ repository.revision }</echo>
</target>



---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message