ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dominique Devienne" <ddevie...@gmail.com>
Subject Re: Ant 1.6.5 , JDK 1.5 build error pointing to an apache class
Date Sat, 18 Mar 2006 03:28:44 GMT
> [C:\builder\builds\fle\staging\src\com\myhome\ParamDataType.java:8: as
> of release 1.5, 'enum' is a keyword, and may not be used as an
> identifier
>    [javac] (try -source 1.4 or lower to use 'enum' as an identifier)
>    [javac] import org.apache.commons.lang.enum.Enum;
>    [javac]                                ^
>
> I would rather not try the -source 1.4 arg.  Is there any work around,
> or am I looking at some refactoring.

You have no choice if you want to use 1.5 sources, you must change the
code. If you can't or won't, you'll be stuck with 1.4 sources. This is
not an Ant question, BTW... --DD

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message