ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ondrej Svetlik <ond...@svetlik.info>
Subject Re: problem with compiler settings
Date Tue, 14 Feb 2006 22:49:08 GMT
bill/wilandra wrote:
> I don't think the compiler version has anything to do with the error. It
> looks like you have presented 2 packages (com.sun.net.ssl and class
> javax.net.ssl) to the compiler each of which contains the TrustManager
> class. Since the reference to the TrustManager class in the SSLSocketThread
> class is not fully qualified the compiler is having trouble resolving which
> TrustManager class to use. I would guess that you either need to remove one
> of the packages or fully qualify the reference to the TrustManager class.
> 
> It might also help to see which compiler is being used to run the Ant file
> with -verbose.
> 
> HTH Bill
> 

You are right, but the question was how to compile with java 1.2, not 
how to fix the broken code :-). And javac really complains about the 
choice of compiler:

     [javac] This version of java does not support the classic compiler;
upgradin g to modern

I hope it's really what Erik wanted to know. Yes, you are right, that by 
default, ant uses the same java it is running in for javac/java tasks. 
That's why the only way to change it is by setting executable to the one 
desired and fork to true.

Best regards

Ondrej Svetlik

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message