ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Erik Weibust <e...@weibust.net>
Subject Re: problem with compiler settings
Date Tue, 14 Feb 2006 22:50:35 GMT
Thanks for the help.  The only thing I had to change was using classic
instead of 1.2 as the value to my compiler attribute.

I am bothered that I couldn't get the correct behavior by just setting:
<property name="build.compiler" value="classic"/>

erik

On 2/14/06, Ondrej Svetlik <ondrej@svetlik.info> wrote:
> Casey Daniell wrote:
> > Try setting just the javac process...
> >
> >   <javac srcdir="${src}"
> >          destdir="${build}"
> >          fork="true"
> >          source="1.2"
> >          target="1.2"
> >   />
> >
> > OR
> >
> >   <javac srcdir="${src}"
> >          destdir="${build}"
> >          fork="yes"
> >          executable="/opt/java/jdk1.2/bin/javac"
> >          compiler="javac1.2"
> >   />
> >
>
> Hello, I'm afraid the first version won't work. Use the second one, fork
> must be true, executable set to the javac.exe from your jdk1.2
> installation (for example: c:\java\jdk1.2\bin\javac.exe). I think that
> compiler attribute is ignored when executable is set. You may try to set
> target attribute, but in my oppinion it is not necessary.
>
> Best regards
>
> Ondrej Svetlik
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>


--
Erik Weibust
developer, blogger - http://erik.weibust.net
co-leader Spring Dallas User Group - http://SpringDallasUG.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message