ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Chon, Ae H" <AE.H.C...@saic.com>
Subject Problems using 'mail' task, not able to attach html file
Date Tue, 03 Jan 2006 19:49:07 GMT
All,

 

I have the following ant mail task configured.  But it is unable to attach
the 'build.html' file as part of the email but rather expand file as part of
the email message.

 

                  <mail mailhost= "${mail.host}" 

                              subject     = "BUILD FAILED" 

                              charset = "utf-8" 

                              failonerror = "false" 

                              tolist      =
"${cm.list.address},${metrics.address}"

                              messagemimetype = "text/html">

                              <from address     = "${from.address}" />

                              <message>Build failed due to
errors!&#10;&#10;</message>

                              <fileset dir = "${log.build.dir}">

                                    <include name = "build.html"/>

                              </fileset>

                  </mail>

 

The email contents look like the following when sent.

 

Build failed due to errors! begin 644 build.html
M/&AT;6P^#0H\:&5A9#X-"CQ-151!(&AT=' M97%U:78](D-O;G1E;G0M5'EP
M92(@8V]N=&5N=#TB=&5X="]H=&UL.R!C:&%RPT*(" @(" @;6%R9VEN.B...

 

I cannot figure out what's going on.

 

Thanks for you help.

Ae Hwa Chon
Configuration Manager
SAIC
5113 Leesburg Pike
Skyline 4, Suite 502
Falls Church, VA 22041-3220
(W)  703-824-5863

 


Mime
  • Unnamed multipart/alternative (inline, None, 0 bytes)
View raw message