ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <anto...@gmx.de>
Subject Re: Deployment to Websphere 6
Date Fri, 06 Jan 2006 10:24:19 GMT
Hello Sam,

there are cases where the only options which really work are :


a) use one of the options below

    * -lib jars in the order specified by the -lib elements on the
      command line
    * jars from ${user.home}/.ant/lib (unless -nouserlib is set)
    * jars from ANT_HOME/lib

or

b) put the required jar file in the CLASSPATH environment variable
before you start ant
(would work, not recommended)


behind these suggestions : if the bootstrap.jar is really containing the
missing class com/ibm/ws/bootstrap/WSLauncher,
a possible explanation why the class is not found could be that the
class gets instantiated by another class which is in a "higher" classloader,
which does not delegate back to "children" classloaders.

Also, try to decompile this WSLauncher class, and make sure that it is
not referring to another class which would not be in your classpath.
For instance if WSLauncher extends say GenericLauncher and
GenericLauncher is not in your classpath, this might also result in the
NoClassDefFoundError (not sure).


Antoine



Sam.Tandy@euroclear.com wrote:

>Hi,
>
>I am automating the deployment of an Ear file to Websphere 6 using Ant
>1.6.5.
>I've been doing this with no problems using Websphere 5 but encountering
>problems when now using Websphere 6 and the same deployment code.
>
>I use the ant tasks defined in wsanttask.jar which comes bundled with
>Websphere. Firstly, I simply try to stop an application.
>I define a new ant task mapped to the required class in the wsanttask.jar
>then use it in the build file:
>
>  <target name="Stop App" >
>    <stopApp wasHome="XXX" server="XXX" application="XXX" />
>  </target>
>
>This is the same as for Websphere 5 but on Websphere 6 I receive the
>following error:
>
>java.lang.NoClassDefFoundError: com/ibm/ws/bootstrap/WSLauncher
>
>I have tried adding the jar file to the classpath of Ant, WS and copying
>the required jar (bootstrap.jar, I believe) into the Ant lib directory.
>
>This should be a very simple step to perform but I cannot solve this. Does
>anyone have any ideas?
>
>Thanks,
>Sam.
>
>
>  
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message