ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alexey N. Solofnenko" <a.solofne...@mdl.com>
Subject Re: Problems using 'mail' task, not able to attach html file
Date Tue, 03 Jan 2006 22:00:06 GMT
Unless there is something wrong with your particular HTML attachment, 
please check your classpath. Is it possible that you have some old 
JAF/JavaMail there. Please also check ANT's and JRE lib/** folders.

- Alexey.

Chon, Ae H wrote:
> I removed the charset attribute and getting the following message.
>
>     [mail] Failed to initialise MIME mail: javax/activation/DataSource
>     [mail] Sending email: BUILD FAILED:  TurboPlanner 0.3.0.52
>     [mail] Sent email with 1 attachment
>
> It says it sent it with 1 attachment; but what it actually does is it
> expands the contents of html as part of the email message.  This was what it
> was doing before.
>
> Any other suggestions?
>
> -Ae Hwa
> -----Original Message-----
> From: user-return-53972-AE.H.CHON=saic.com@ant.apache.org
> [mailto:user-return-53972-AE.H.CHON=saic.com@ant.apache.org] On Behalf Of
> Ivan Ivanov
> Sent: Tuesday, January 03, 2006 3:01 PM
> To: Ant Users List
> Subject: Re: Problems using 'mail' task, not able to attach html file
>
> Hello,
>
> Can you try without charset attribute?
>
> Regards
> Ivan
>
> --- "Chon, Ae H" <AE.H.CHON@saic.com> wrote:
>
>   
>> All,
>>
>>  
>>
>> I have the following ant mail task configured.  But
>> it is unable to attach
>> the 'build.html' file as part of the email but
>> rather expand file as part of
>> the email message.
>>
>>  
>>
>>                   <mail mailhost= "${mail.host}" 
>>
>>                               subject     = "BUILD
>> FAILED" 
>>
>>                               charset = "utf-8" 
>>
>>                               failonerror = "false" 
>>
>>                               tolist      =
>> "${cm.list.address},${metrics.address}"
>>
>>                               messagemimetype =
>> "text/html">
>>
>>                               <from address     =
>> "${from.address}" />
>>
>>                               <message>Build failed
>> due to
>> errors!
>>     
>
> </message>
>   
>>                               <fileset dir =
>> "${log.build.dir}">
>>
>>                                     <include name =
>> "build.html"/>
>>
>>                               </fileset>
>>
>>                   </mail>
>>
>>  
>>
>> The email contents look like the following when
>> sent.
>>
>>  
>>
>> Build failed due to errors! begin 644 build.html
>> M/&AT;6P^#0H\:&5A9#X-"CQ-151!(&AT='
>> M97%U:78](D-O;G1E;G0M5'EP
>> M92(@8V]N=&5N=#TB=&5X="]H=&UL.R!C:&%RPT*(" @("
>> @;6%R9VEN.B...
>>
>>  
>>
>> I cannot figure out what's going on.
>>
>>  
>>
>> Thanks for you help.
>>
>> Ae Hwa Chon
>> Configuration Manager
>> SAIC
>> 5113 Leesburg Pike
>> Skyline 4, Suite 502
>> Falls Church, VA 22041-3220
>> (W)  703-824-5863
>>
>>  
>>
>>
>>     
>
>
>
> 		
> __________________________________________ 
> Yahoo! DSL - Something to write home about. 
> Just $16.99/mo. or less. 
> dsl.yahoo.com 
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>   

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message