ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erskine, Chris" <chris.ersk...@eds.com>
Subject RE: websphere script install problem
Date Tue, 03 Jan 2006 12:32:01 GMT
Also, related to this, execute the wsadmin command outside of Ant and
debug it.  There is also a way to define the virtual host within JACL if
you do not have the xmi file.

Chris Erskine
 
EDS Consulting Services
Colorado Springs, CO 
 
Phone: 719-265-5962
Cell: 719-640-6488
-----Original Message-----
From: Andrew Goktepe [mailto:andrewgoktepe@gmail.com] 
Sent: Monday, January 02, 2006 6:55 PM
To: Ant Users List
Subject: Re: websphere script install problem

This is a WebSphere problem, not an ANT problem.

I do have a suggestion, though. Expand the war file and take a look at
the
ibm-web-bnd.xmi deployment descriptor. The <webappbnd:WebAppBinding> tag
should have a 'virtualHostName' attribute, which should probably have a
value of 'default_host'.

If this does not help you with your problem, try posting your question
to
the WebSphere forums.

-Andrew


On 1/2/06, Alan Andrade <aandrade@contractor.epolicysolutions.com>
wrote:
>
> Can somebody help debug this error Log
>
>
>
> [echo] Install the EAR...
>
>
>
>     [echo] Exec: d:/was/bin/wsadmin.bat
>
>     [echo] Command: wsadmin -f jacl-file server-name node-name
cell-name
> app-name was-home re-config
>
>     [echo] jacl-file: epspal.jacl
>
>     [echo] server-name: server1
>
>     [echo] node-name: DRRCWEB
>
>     [echo] cell-name: DRRCWEB
>
>     [echo] app-name: RightRisk7.0
>
>     [echo] was-home: d:/was
>
>     [echo] re-config: true
>
>
>
>     [exec] WASX7209I: Connected to process "server1" on node DRRCWEB
using
> SOAP connector;  The type of process is: UnManagedProcess
>
>
>
>
>
>     [exec] Checking for the RightRisk7.0 Enterprise Application...
>
>     [exec] RightRisk7.0 Enterprise Application is not installed.
>
>     [exec] Checking for the RightRisk7.0 Enterprise Application...Done
>
>
>
>
>
>     [exec] Installing the RightRisk7.0 Enterprise Application.1..
>
>     [exec] WASX7017E: Exception received while running file
"epspal.jacl";
> exception information: com.ibm.ws.scripting.ScriptingException:
WASX7109E:
> Insufficient data for install task "MapWebModToVH
>
>
>
>     [exec] ADMA0010E: Validation error in task Selecting Virtual Hosts
for
> Web Modules
>
>     [exec]   Virtual host is not specified for web module RightRisk
> Application with URI rr7.war,WEB-INF/web.xml."
>
>
>
>
>
>
>
> Clearly it says it cannot find info about  Selecting Virtual Hosts!!!
The
> value to be selected is "default_port" !!!
>
> The problem is where do I enter the value?
>
>
>
> Thanks
>
> Alan
>
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message