ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rhino" <rhi...@sympatico.ca>
Subject Javadoc problem
Date Wed, 11 Jan 2006 18:53:21 GMT
I'm having an odd problem with a Javadoc task in Ant 1.6.5. I'm using 
Eclipse but I have a second copy of Ant 1.6.5 outside of Eclipse and the 
exact same thing happens regardless of whether I run the build within 
Eclipse or outside of it.

The Javadoc is writing the docs for 5 packages. I've created a 
package-info.java file for each of those packages with a few lines of 
documentation. Each package-info.java file was created in the same way and 
has similar brief contents with similar Javadoc tags. However, when I look 
at the generated Javadocs, I'm only getting the package comments for one of 
the five packages; the rest don't appear to have been 'seen' by the Javadoc 
task.

I don't know how to debug this. If none of the package-info documentation 
was appearing, I'd assume I'd created those files incorrectly or had 
specified parameters to the javadoc task incorrectly. But one of the five 
worked just fine while the other four didn't get picked up, even though all 
were created in exactly the same way.

Can anyone suggest a strategy to figure out why _some_ of the package-info 
documentation isn't appearing?

Let me explain a little more clearly what is and isn't appearing in my 
Javadocs. My five package names are:
- com.foo.common
- com.foo.common.utilities
- com.foo.resume
- com.foo.resume.misc
- com.foo.resume.Resources

First, in the Javadoc overview, each of my five packages are showing up in 
the Other Packages table. Only one of them, com.foo.resume.Resources, has a 
comment in the second column; that comment is the one from the first line of 
the package-info.java file for that package. The other four packages have no 
comments at all in the Other Packages table.

On the "package" pages for each package, the Enum Summary, Class Summary, 
and Interface Summary tables contains the names of the appropriate enums, 
classes, and interfaces and each of them has a comment, taken from the 
Javadoc comments for the individual enum, class or interface. However, only 
com.foo.resume.Resources has the package-info.java comments for its classes.

The contents of each package-info.java file look like this:
/**
 * This package contains blah blah blah.
 *
 * @author Rhino
 * @version 1.0
 */
package com.foo.resume;

(Naturally, the package name in the package statement varies in each case. 
Each package-info.java file is situated in the source tree of its package 
and contains its proper package name.)

This is my javadoc task:
--------------------------------------------------------------------------------------------------------------
 <javadoc destdir="${resume.javadoc.dir}"
  author="true"
  version="true"
  use="true"
  splitindex="true"
  access="private"
  executable="${javadoc.path}"
  source="1.5"
  windowtitle="R\u00e9sum\u00e9 API"
  breakiterator="true"
      overview="${resume.html.dir}\javadoc_overview.html" doctitle="Resume 
Overview"
  classpath="${iText.jar}:${common.bin}"
  description="Generate Javadocs for the project">

  <fileset dir="${resume.src}" defaultexcludes="yes">
   <patternset refid="ps.resume"/>
   </fileset>
  <fileset dir="${resume.misc.src}" defaultexcludes="yes">
   <patternset refid="ps.resume.misc"/>
   </fileset>
  <fileset dir="${common.src}" defaultexcludes="yes">
   <patternset refid="ps.common"/>
   </fileset>

  <doctitle><![CDATA[<h1>R&eacute;sum&eacute;</h1>]]></doctitle>
  <bottom><![CDATA[<i>Copyright &#169; 2006 Rhino. All Rights 
Reserved.</i>]]></bottom>
  <group title="R\u00e9sum\u00e9 Packages" packages="resume*"/>
  <group title="Common Packages" packages="common*"/>
  <link href="http://java.sun.com/j2se/1.5.0/docs/api"/>
  </javadoc>

--------------------------------------------------------------------------------------------------------------


Can anyone help me figure out what is going wrong here?


---
Rhino



-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.371 / Virus Database: 267.14.17/226 - Release Date: 10/01/2006


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message