ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Bedre Atmaling Baburao <bedre.babu...@tavant.com>
Subject RE: Ant Deploy failure in weblogic 8.1
Date Fri, 30 Dec 2005 04:53:48 GMT
Hi,
	Just go through this link, it will tells all about deployment using
wldeploy.
	http://e-docs.bea.com/wls/docs90/programming/wldeploy.html#1000477
	I have use this undeploy and deploy target mentioned in above link.
 	Currently i am running five different servers on different port
which use this task.

Bedre


-----Original Message-----
From: Srikrishna_Parthasarathy@timeinc.com
[mailto:Srikrishna_Parthasarathy@timeinc.com]
Sent: Thursday, December 29, 2005 8:50 PM
To: bedre.baburao@tavant.com
Subject: RE: Ant Deploy failure in weblogic 8.1


Can share your target to the group ?Include the custom typedef for
wldeploy also.

-----Original Message-----
From: Bedre Atmaling Baburao [mailto:bedre.baburao@tavant.com] 
Sent: Thursday, December 29, 2005 7:01 AM
To: Ant Users List
Subject: RE: Ant Deploy failure in weblogic 8.1

Hi,
	Thanks to Srikrishna. As you suggest the wldeploy task.
	This wldeploy task works fine. There I have to just specify the
location of ear and adminurl.

Bedre


-----Original Message-----
From: Srikrishna_Parthasarathy@timeinc.com
[mailto:Srikrishna_Parthasarathy@timeinc.com]
Sent: Tuesday, December 27, 2005 8:48 PM
To: user@ant.apache.org
Subject: RE: Ant Deploy failure in weblogic 8.1


>From Weblogic 8.1, there is a custom ant task for deployment call
wldeploy. After getting it right, please share it to the group .

Hope this helps.

Srikrishna

-----Original Message-----
From: Petar Tahchiev [mailto:paranoiabla@gmail.com] 
Sent: Tuesday, December 27, 2005 2:42 AM
To: Ant Users List
Subject: Re: Ant Deploy failure in weblogic 8.1

On 26/12/05, Bedre Atmaling Baburao <bedre.baburao@tavant.com> wrote:
>
> Hi,
>         I am running the  following ant target. and getting the
exception.
> through this target my server is running and also the weblogic is able
to
> upload the mentioned ear to the upload folder in weblogic.But the
> exception
> is getting while extracting the
> the ear. if any bosy know solution,plz reply me
>
> thanks
>
> target is:
>
> <serverdeploy action="deploy"
> source="D:/Ears/26-December-2005_ITR5_RC6/Homer.ear" >
>                                 <weblogic application="Homer"
>
server="t3://${host}:${homer.port}"
>
> classpath="${weblogic.lib.dir}/weblogic.jar"
>                                     username="${wls.username}"
>                                     password="${wls.password}"
>                                          component="Homer:myserver"
>                                     debug="true"/>
>                             </serverdeploy>
>
> the Exception is :
>
>
>      [java]  Unexpected error executing the deploy
> toolweblogic.management.ManagementRuntimeException:
> java.util.zip.ZipException: error in opening zip file
>      [java] java.util.zip.ZipException: error in opening zip file
>
> BUILD FAILED
> file:D:/HomerCVS1/Homer/dev/application/scripts/build-release.xml:96:
Java
> returned: 1
>         at org.apache.tools.ant.taskdefs.Java.execute(Java.java:110)
>         at
>
>
org.apache.tools.ant.taskdefs.optional.j2ee.WebLogicHotDeploymentTool.de
ploy
> (WebLogicHotDeploymentTool.java:107)
>         at
> org.apache.tools.ant.taskdefs.optional.j2ee.ServerDeploy.execute
> (ServerDeplo
> y.java:146)
>         at org.apache.tools.ant.Task.perform(Task.java:341)
>         at org.apache.tools.ant.Target.execute(Target.java:309)
>         at org.apache.tools.ant.Target.performTasks(Target.java:336)
>         at
org.apache.tools.ant.Project.executeTarget(Project.java:1339)
>         at
org.apache.tools.ant.Project.executeTargets(Project.java:1255)
>         at org.apache.tools.ant.Main.runBuild(Main.java:609)
>         at org.apache.tools.ant.Main.start(Main.java:196)
>         at org.apache.tools.ant.Main.main(Main.java:235)
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>
I have also used Weblogic for a while and noticed that kind of exception
is
thrown in the konsole sometimes. I don't really know why it is thrown
and
would be thankful to know the solution. As I noticed the hotdeploy
directory
of weblogic is checking in some amount of time whether the ear you
deployed
is newer. So in my opinion the exception is thrown when you copy the
ready
ear to the directory in the middle of the "checking" proccess. In my
case
whenever I would see such an exception I would just touch the archive
and a
few seconds later it would be deployed successfully. But I can assure
you
that this is ant related problem, for I have also used the "copy" task
and
the excepion was still thrown sometimes.

--
Regards, Petar!

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message