ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Mikael Petterson (KI/EAB)" <mikael.petter...@ericsson.com>
Subject RE: ant-user OutOfMemoryException
Date Thu, 08 Dec 2005 14:46:33 GMT
Sorry I did not know tht you were using ant within eclipse. The lines that I gave you were
if you were building with 
ant from cli.

But as said by Jonnalagadda, Sumithra increase Xms and Xmx for JRE. If that does not work
you can alway increase heap for 
eclipse ( let me know on the mailing list).

Any luck so far?

cheers,

//mikael
From: Ferrer, Eric [mailto:eric.ferrer@transcore.com]
Sent: den 7 december 2005 22:01
To: Ant Users List
Subject: RE: ant-user OutOfMemoryException


Can not seem to find a way to set the setting on each individual
project.  I am running Eclipse 3.0.  I went to each project and right
clicked and searched for such setting.

Thanks

-----Original Message-----
From: Jonnalagadda, Sumithra [mailto:sumithra@amgen.com] 
Sent: Wednesday, December 07, 2005 1:47 PM
To: 'Ant Users List'
Subject: RE: ant-user OutOfMemoryException

we faced same issue in our project.

Try setting the memory for each individual project in eclipse. It helped
us;
i hope it helps u too.

-----Original Message-----
From: Ferrer, Eric [mailto:eric.ferrer@transcore.com]
Sent: Wednesday, December 07, 2005 12:39 PM
To: Ant Users List
Cc: mikael.petterson@ericsson.com
Subject: RE: ant-user OutOfMemoryException


No I did not,  I have an ant build script in eclipse and it talks to
other projects build scripts via the dependencies.  A couple of the
projects become jars and the result is the output of 2 war files that
get deployed to tomcat.  

I can build fine without unit tests, but get OME on unit test only.
I have tried invoking System.gc in our interface that extends the Test
case method on its teardown.  Still get OME.



-----Original Message-----
From: Jonnalagadda, Sumithra [mailto:sumithra@amgen.com] 
Sent: Wednesday, December 07, 2005 1:33 PM
To: 'Ant Users List'
Subject: RE: ant-user OutOfMemoryException


Did you try setting it for reach project in your workspace seperately?.
-----Original Message-----
From: ferrerctst@cox.net [mailto:ferrerctst@cox.net]
Sent: Wednesday, December 07, 2005 8:49 AM
To: user@ant.apache.org
Cc: mikael.petterson@ericsson.com
Subject: ant-user OutOfMemoryException


Mikael,

Thanks for the reply, I honestly did not get my hope up as the community
boards (where Apache wants us to ask around first since they offer no
support) was not responsive.


I am using 1.6.2 and have even switched to 1.6.5 hoping it would solve
some
of my problems.  I basically inherited this role as some core project
people
left before i joined the company.  I did have the ANT_OPS setting but
that
was not working..I will try your suggestings today. 


> 
> From: "Mikael Petterson (KI/EAB)" <mikael.petterson@ericsson.com>
> Date: 2005/12/07 Wed AM 01:35:27 EST
> To: <ferrerctst@cox.net>
> Subject: RE: ant-user OutOfMemoryException
> 
> Hi,
> 
> Yes I resolved it. The thing is that using  ANT_OPTS  to increase Xmx
and
Xms does not seem to have any affect on the jvm starting ant.
> However when I increase the heap using Xmx and Xms to the jvm starting
ant
it works! It does not seem that ANT_OPTS is recognized.
> 
> This is the line I am using to start ant in my wrapper shell script:
> 
> $JAVACMD $ANT_OPTS -Xbootclasspath/p:$XALAN:$XERCES_IMPL:$XML_APIS
-classpath "${ANT_HOME}/lib/ant-launcher.jar" "-Dant.home=${ANT_HOME}"
org.apache.tools.ant.launch.Launcher -lib $JUNIT  $*
> 
> Don't mind the Xbootclasspath. 
> 
> If you have any luck let me know.I am using ant 1.6.2. Which version
are
you using?
> 
> please post to user@ant.apache.org and cc me. I will assist as much as
possible.
> 
> cheers,
> 
> //mikael
> 
> -----Original Message-----
> From: ferrerctst@cox.net [mailto:ferrerctst@cox.net]
> Sent: den 7 december 2005 01:01
> To: Mikael Petterson (KI/EAB)
> Subject: ant-user OutOfMemoryException
> 
> 
> Hi Mikael,
> 
> I saw your post about OutOfMemoryException with Ant.  Did you ever get
it
resolved?  I have a similar issue but when running JUNIT Tests during
the
build process.
> 
> Thanks
> 
> -Eric
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message