ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Antoine Levy-Lambert <anto...@gmx.de>
Subject Re: AW: Installing ant on AIX 5.2
Date Wed, 07 Dec 2005 19:57:24 GMT
Hello Arnault,

you can open a bug report on http://issues.apache.org/bugzilla (see our
web site, bug database).
If you can offer us a patch for bootstrap.sh, it is appreciated.

Cheers,

Antoine

Jan.Materne@rzf.fin-nrw.de wrote:

>Ant is just a java application ... I think the standard binary distro should work?
>
>But not bootstrapping under AIX is another problem.
>
>Jan 
>
>  
>
>>-----Urspr√ľngliche Nachricht-----
>>Von: Arnault BELLINA [mailto:kataplute@yahoo.fr] 
>>Gesendet: Mittwoch, 7. Dezember 2005 09:21
>>An: user@ant.apache.org
>>Betreff: Installing ant on AIX 5.2 
>>
>>Hi all ! 
>> 
>> I'm trying to install Apache ant 1.6.5 on AIX 5.2. I 
>>unpacked  the  tar file and I tried as mentionned in the 
>>Building ant Manual to build  ant from sources.
>> 
>> However when i build ant with the script build.sh I had a 
>>problem with the underscript bootstrap.sh : 
>> 
>> I get this error : 
>> 
>> ./build.sh -Ddir.dist=ant dist
>> 
>> ... Bootstrapping Ant Distribution
>> ... Compiling Ant Classes
>> ./bootstrap.sh[130]: /usr/java14/sh/javac: arg list too long
>> ... Failed compiling Ant classes !
>> Bootstrap FAILED
>> 
>> 
>> I find that the problem come from the code : 
>> 
>> "${JAVAC}" $BOOTJAVAC_OPTS -d ${CLASSDIR} 
>>${TOOLS}/bzip2/*.java ${TOOLS}/tar/*.java ${TOOLS}/zip/*.java \
>>     ${TOOLS}/ant/util/regexp/RegexpMatcher.java \
>>     ${TOOLS}/ant/util/regexp/RegexpMatcherFactory.java \
>>     ${TOOLS}/ant/types/*.java \
>>     ${TOOLS}/ant/taskdefs/compilers/*.java \
>>     ${TOOLS}/ant/taskdefs/condition/*.java \
>>     ${TOOLS}/ant/*.java ${TOOLS}/ant/taskdefs/*.java
>> ret=$?
>> if [ $ret != 0 ]; then
>>   echo ... Failed compiling Ant classes !
>>   exit $ret
>> fi
>> 
>> I try to separate the instruction in two part but I get a 
>>new error when the build.sh script use the build.xml file.
>> 
>> Is there any solution to correct the JAVAC compilation to 
>>make it works  ? Is there anybody who had this error. Or does 
>>it exist some binary of  ant  that works  on AIX 5.2
>> 
>> Thanks a lot
>> 
>> Arnault 
>>    
>>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message