ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anderson, Rob (Global Trade)" <Rob.Ander...@nike.com>
Subject RE: Intermittent problem with input task
Date Wed, 21 Dec 2005 18:58:56 GMT
Does it work consistenly from the command line, outside of eclipse? If
so, it is likely a problem with the input handler that eclipse uses, or
eclipse itself, not ant.

-Rob Anderson

> -----Original Message-----
> From: Rhino [mailto:rhino1@sympatico.ca] 
> Sent: Wednesday, December 21, 2005 10:00 AM
> To: ant-user
> Subject: Intermittent problem with input task
> 
> I've been having an intermittent problem with the 'input' 
> task for the past several days. I'm baffled by what causes it 
> and would like to know if anyone else has seen this or knows 
> of a solution/workaround to keep it from happening?
> 
> I'm using Ant 1.6.5 in Eclipse 3.1.1 and my problem is 
> simple: my 'input' 
> task _occasionally_ fails to bring up the input dialog. Even 
> with -verbose and -debug in my startup parameters, the Ant 
> output simply shows the name of the target that contains the 
> input task with no other output, like so:
> getserver:
> 
> 
> The build doesn't seem to succeed _or_ fail; there is nothing 
> after the 'getserver:' line. However, the build seems to have 
> ended because I can launch it again without a problem.
> 
> I was getting this problem very persistently a few days ago, 
> then it went away suddenly. Now it is back. I can't think of 
> anything I have done in my build script or my environment to 
> cause my 'input' task to work or fail intermittently; the 
> target is itself has been working unchanged for a couple of 
> years until this problem started the other day. Here is the target:
> 
> <target name="getserver" description="Determine which server 
> is the target">
>  <input message="Which server should receive the files? 1. 
> Silo   2. Bongo"
>   validargs="1,2"
>   addproperty="server.choice"
>   defaultvalue="2"/>
>  <condition property="servername" value="Silo">
>   <equals arg1="${server.choice}" arg2="1"/>
>   </condition>
>  <condition property="servername" value="Bongo">
>   <equals arg1="${server.choice}" arg2="2"/>
>   </condition>
> </target>
> 
> Can anyone help me figure out how to get the 'input' task 
> working _all_ of the time? This is really messing me up. I 
> have several input tasks to prompt for input that should not 
> be hard-coded in the script for security reasons.
> 
> Rhino
> 
> 
> 
> --
> No virus found in this outgoing message.
> Checked by AVG Free Edition.
> Version: 7.1.371 / Virus Database: 267.14.2/208 - Release 
> Date: 20/12/2005
> 
> 
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
> 
> 
> 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message