ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Rhino" <rhi...@sympatico.ca>
Subject Re: Intermittent problem with input task
Date Wed, 21 Dec 2005 19:43:48 GMT
I just tried the build from the command line outside of Eclipse.

I got the build to work but it definitely acted wonky on the getserver 
target:
- Ant displayed the message asking me to choose a server
- I typed 2 and pressed Enter
- the build just sat there until I pressed Enter
- Ant displayed the message asking me to choose a server AGAIN
- I typed 2 and pressed Enter
- this time it accepted the answer and went on to other targets, some of 
which included their own input tasks. But all of the other input tasks 
worked fine, i.e. they accepted the input the first time.

I tried the build from the command line a second time and got exactly the 
same behaviour the second time choosing the other server.

I haven't changed the getserver target one iota since running it 
successfully in older versions of Ant - 1.6.1 and 1.6.2 - so I'm wondering 
if a new bug has been introduced to 'input' between 1.6.2 and 1.6.5? Mind 
you, that doesn't explain why the other input tasks work fine; you'd think 
they'd misbehave, too.

Or is this normal behaviour for 'input' when executed from the command line? 
I don't think I've ever executed a build with an input task from the command 
line before.

Rhino

----- Original Message ----- 
From: "Anderson, Rob (Global Trade)" <Rob.Anderson@nike.com>
To: "Ant Users List" <user@ant.apache.org>
Sent: Wednesday, December 21, 2005 1:58 PM
Subject: RE: Intermittent problem with input task


Does it work consistenly from the command line, outside of eclipse? If
so, it is likely a problem with the input handler that eclipse uses, or
eclipse itself, not ant.

-Rob Anderson

> -----Original Message-----
> From: Rhino [mailto:rhino1@sympatico.ca]
> Sent: Wednesday, December 21, 2005 10:00 AM
> To: ant-user
> Subject: Intermittent problem with input task
>
> I've been having an intermittent problem with the 'input'
> task for the past several days. I'm baffled by what causes it
> and would like to know if anyone else has seen this or knows
> of a solution/workaround to keep it from happening?
>
> I'm using Ant 1.6.5 in Eclipse 3.1.1 and my problem is
> simple: my 'input'
> task _occasionally_ fails to bring up the input dialog. Even
> with -verbose and -debug in my startup parameters, the Ant
> output simply shows the name of the target that contains the
> input task with no other output, like so:
> getserver:
>
>
> The build doesn't seem to succeed _or_ fail; there is nothing
> after the 'getserver:' line. However, the build seems to have
> ended because I can launch it again without a problem.
>
> I was getting this problem very persistently a few days ago,
> then it went away suddenly. Now it is back. I can't think of
> anything I have done in my build script or my environment to
> cause my 'input' task to work or fail intermittently; the
> target is itself has been working unchanged for a couple of
> years until this problem started the other day. Here is the target:
>
> <target name="getserver" description="Determine which server
> is the target">
>  <input message="Which server should receive the files? 1.
> Silo   2. Bongo"
>   validargs="1,2"
>   addproperty="server.choice"
>   defaultvalue="2"/>
>  <condition property="servername" value="Silo">
>   <equals arg1="${server.choice}" arg2="1"/>
>   </condition>
>  <condition property="servername" value="Bongo">
>   <equals arg1="${server.choice}" arg2="2"/>
>   </condition>
> </target>
>
> Can anyone help me figure out how to get the 'input' task
> working _all_ of the time? This is really messing me up. I
> have several input tasks to prompt for input that should not
> be hard-coded in the script for security reasons.
>
> Rhino
>
>
>
> --
> No virus found in this outgoing message.
> Checked by AVG Free Edition.
> Version: 7.1.371 / Virus Database: 267.14.2/208 - Release
> Date: 20/12/2005
>
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


-- 
No virus found in this incoming message.
Checked by AVG Free Edition.
Version: 7.1.371 / Virus Database: 267.14.2/208 - Release Date: 20/12/2005




-- 
No virus found in this outgoing message.
Checked by AVG Free Edition.
Version: 7.1.371 / Virus Database: 267.14.2/208 - Release Date: 20/12/2005


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message