ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Safak Ökmen <oek...@in.tum.de>
Subject Re: ant not recognizing command line argument
Date Thu, 01 Dec 2005 16:35:31 GMT
Hi Matt,

here is the output:

__________

D:\programme\ant\bin>D:\programme\ant\bin\ant.bat clean
Buildfile: build.xml

one:

BUILD SUCCESSFUL
Total time: 0 seconds
D:\programme\ant\bin>

_______________


Is it possibly interacting with the exlipse plugin ant?

Safak.

Matt Benson wrote:
> Are you the first owner of this box?  I would
> thoroughly investigate the possibility that the ant
> you installed is not the ant that is being called.
> Try using full paths when you run ant for a quick
> check; i.e. D:\programme\ant\bin\ant.bat ....
>
> HTH,
> Matt
>
> --- Safak Ökmen <oekmen@in.tum.de> wrote:
>
>> Here is another sample:
>>
>> __________
>> D:\programme\ant\bin>ant -debug clean
>> Buildfile: build.xml
>>
>> one:
>>
>> BUILD SUCCESSFUL
>> Total time: 1 second
>> D:\programme\ant\bin>vim build.xml
>>
>> D:\programme\ant\bin>ant -debug
>> Buildfile: build.xml
>>
>> one:
>>
>> BUILD SUCCESSFUL
>> Total time: 0 seconds
>> D:\programme\ant\bin>ant clean -debug
>> Buildfile: build.xml
>>
>> one:
>>
>> BUILD SUCCESSFUL
>> Total time: 0 seconds
>> D:\programme\ant\bin>ant clean
>> Buildfile: build.xml
>>
>> one:
>>
>> BUILD SUCCESSFUL
>> Total time: 0 seconds
>> D:\programme\ant\bin>ant hello
>> Buildfile: build.xml
>>
>> one:
>>
>> BUILD SUCCESSFUL
>> Total time: 0 seconds
>> D:\programme\ant\bin>
>>
>> __________
>>
>>
>> I have rebooted my windows. This was not the
>> problem. I don't know. I
>> reinstalled ant, too.
>>
>> Safak.
>>
>>
>>
>>
>>
>>
>>
>>
>>
>>
>> Jan.Materne@rzf.fin-nrw.de wrote:
>>> I tried you buildfile from [1] - commented only
>> the jflex-taskdef out
>>> - and
>>> that worked for me.
>>> But your output [2] doesnt seem to fit to your buildfile.
>>>
>>> On your machine the execution order was
>>> "init,copygen,classes,shared,javadoc,all"
>>> but called was "ant clean" - never have seen that before.
>>>
>>> So again, what does -debug say?
>>>
>>>
>>> Jan
>>>
>>>
>>> [1] http://phpfi.com/89578
>>> [2] http://home.in.tum.de/~oekmen/antFailure.JPG
>>>
>>>
>>>
>>
> ---8-<-------8-<-------8-<-------8-<-------8-<-------8-<-------8-<-------8-<----
>>> C:\TEMP\ant-test6>ant init
>>> Buildfile: build.xml
>>>
>>> init:
>>>     [mkdir] Created dir: C:\TEMP\ant-test6\bin
>>>     [mkdir] Created dir: C:\TEMP\ant-test6\dist
>>>     [mkdir] Created dir: C:\TEMP\ant-test6\etc
>>>     [mkdir] Created dir: C:\TEMP\ant-test6\java
>>>     [mkdir] Created dir: C:\TEMP\ant-test6\docs
>>>
>>> BUILD SUCCESSFUL
>>> Total time: 0 seconds
>>> C:\TEMP\ant-test6>ant clean
>>> Buildfile: build.xml
>>>
>>> clean:
>>>    [delete] Deleting directory
>> C:\TEMP\ant-test6\bin
>>>    [delete] Deleting directory
>> C:\TEMP\ant-test6\dist
>>>    [delete] Deleting directory
>> C:\TEMP\ant-test6\etc
>>>    [delete] Deleting directory
>> C:\TEMP\ant-test6\java
>>>    [delete] Deleting directory
>> C:\TEMP\ant-test6\docs
>>>
>>> BUILD SUCCESSFUL
>>> Total time: 0 seconds
>>> C:\TEMP\ant-test6>ant clean
>>> Buildfile: build.xml
>>>
>>> clean:
>>>
>>> BUILD SUCCESSFUL
>>> Total time: 0 seconds
>>>
>>
> ---8-<-------8-<-------8-<-------8-<-------8-<-------8-<-------8-<-------8-<----
>>>
>>>
>>>> -----Ursprüngliche Nachricht-----
>>>> Von: Safak Ökmen [mailto:oekmen@in.tum.de]
>>>> Gesendet: Mittwoch, 30. November 2005 20:50
>>>> An: Ant Users List
>>>> Betreff: Re: ant not recognizing command line argument
>>>>
>>>> Hi!
>>>>
>>>> I'm sorry.
>>>> Here I have uploaded it on my webpage:
>>>> http://home.in.tum.de/~oekmen/antFailure.JPG
>>>>
>>>> Safak.
>>>>
>>>> Ivan Ivanov wrote:
>>>>> Hello,
>>>>>
>>>>> I am sorry. I am willing to help, morever it seems an easy issue,
>>>>> but your attachment is stripped off. If you want to receive some
>>>>> help, sent the build log inline of the message.
>>>>>
>>>>> Regards
>>>>> Ivan
>>>>>
>>>>> --- Safak �kmen <oekmen@in.tum.de> wrote:
>>>>>
>>>>>> I start it with just
>>>>>> ant (the output should be like on the jpeg) or ant clean (the
>>>>>> output on the jpeg is false for the target clean)
>>>>>>
>>>>>> on command line. See jpeg.
>>>>>>
>>>>>> Safak.
>>>>>>
>>>>>> Ivan Ivanov wrote:
>>>>>>> Hello,
>>>>>>>
>>>>>>> How do you start this build file. Please post the exact command
>>>>>>> with which you start it, as well as
>>>>>> the
>>>>>>> output.
>>>>>>>
>>>>>>> Regards
>>>>>>> Ivan
>>>>>>>
>>>>>>> --- Safak �kmen <oekmen@in.tum.de> wrote:
>>>>>>>
>>>>>>>> Here is the buildfile:
>>>>>>>>
>>>>>>>> http://phpfi.com/89578
>>>>>>>>
>>>>>>>> Safak.
>>>>>>>>
>>>>>>>> Karr, David wrote:
>>>>>>>>> We'd have to see your build file.  I'm
>> guessing your "clean"
>>>>>>>>> target has a dependency which you didn't notice.
>>>>>>>>>
>>>>>>>>>> -----Original Message-----
>>>>>>>>>> From: Safak �kmen
>> [mailto:oekmen@in.tum.de]
>>>>>>>>>> Sent: Wednesday, November 30, 2005 10:59 AM
>>>>>>>>>> To: user@ant.apache.org
>>>>>>>>>> Subject: ant not recognizing command line argument
>>>>>>>>>>
>>>>>>>>>>
>>
> === message truncated ===
>
>
>
>
>
> __________________________________
> Yahoo! Mail - PC Magazine Editors' Choice 2005
> http://mail.yahoo.com
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org 


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message