ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Wulff <ewu...@gmail.com>
Subject Re: can't get optional scp to work - ant 1.6.2
Date Mon, 21 Nov 2005 20:49:42 GMT
got a couple replies and all are much appreciated.  This one was the
fix for my situation.  For future reference, still not sure what the
problem was since I already had a ant-jsch.jar in my ant.home/lib and
it had .class files in it (more than just a manifest).  Still,
downloading the latest jsch-1.1.23.jar and putting in my ant.home/lib
was the fix.

again - many thx - automation is key and this is a big help!
Eric


On 11/21/05, Bozorgdadeh, Afshin <AFSHIN.BOZORGZADEH@fmr.com> wrote:
> Hi Eric,
> It is so funny I was just working on the exact the same problem. The
> hack solution I got to work. Download jsch-0.1.23.jar
> http://www.jcraft.com/jsch/=20 Copy jsch-0.1.23.jar to your ${ANT}/lib
> directory or specify it in your Classpath. Good luck
>
> Best Regards
> Afshin Bozorgzadeh
> >Fidelity Investments Brokerage Company
> >FBCT ClearCase Release Engineer
> Afshin.Bozorgzadeh@fmr.com
> Phone           603-791-5596
> BlackBerry  603-365-0205
>
> -----Original Message-----
> From: Eric Wulff [mailto:ewulff@gmail.com]
> Sent: Monday, November 21, 2005 2:35 PM
> To: Ant Users List
> Subject: can't get optional scp to work - ant 1.6.2
>
> Hi, I'm trying to run the optional scp task (ant 1.6.2 - java 1.4.2)
> but it's complaining.  I feel I've covered the most likely problems
> and now I'm running around with my head cut off  :).
>
> - my usr/local/ant is in my path
> - I have verified the jsch.jar dependency in my ant.home/lib (I've
> tried adding it to my classpath as well, which seems redundant, but
> this didn't help)
> - I have verified that there is more than just a manifest in the .jar
>
> I ran diagnostics and got the following missing dependency...
>
> scp : Missing dependency com.jcraft.jsch.UserInfo
>
> Does that mean ant isn't seeing the jsch.jar at all or that the .jar
> is missing something?
>
> Eric
>
>
> ant output...
>
> Ant could not find the task or a class this task relies upon.
>
> This is common and has a number of causes; the usual
> solutions are to read the manual pages then download and
> install needed JAR files, or fix the build file:
>   - You have misspelt 'scp'.
>    Fix: check your spelling.
>  - The task needs an external JAR file to execute
>      and this is not found at the right place in the classpath.
>    Fix: check the documentation for dependencies.
>    Fix: declare the task.
>  - The task is an Ant optional task and the JAR file and/or libraries
>      implementing the functionality were not found at the time you
>      yourself built your installation of Ant from the Ant sources.
>    Fix: Look in the ANT_HOME/lib for the 'ant-' JAR corresponding to the
>      task and make sure it contains more than merely a
> META-INF/MANIFEST.MF.
>      If all it contains is the manifest, then rebuild Ant with the
> needed
>      libraries present in ${ant.home}/lib/optional/ , or alternatively,
>      download a pre-built release version from apache.org
>  - The build file was written for a later version of Ant
>    Fix: upgrade to at least the latest release version of Ant
>  - The task is not an Ant core or optional task
>      and needs to be declared using <taskdef>.
>  - You are attempting to use a task defined using
>     <presetdef> or <macrodef> but have spelt wrong or not
>    defined it at the point of use
>
> Remember that for JAR files to be visible to Ant tasks implemented
> in ANT_HOME/lib, the files must be in the same directory or on the
> classpath
>
> Please neither file bug reports on this problem, nor email the
> Ant mailing lists, until all of these causes have been explored,
> as this is not an Ant bug.
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
> ---------------------------------------------------------------------
> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
> For additional commands, e-mail: user-help@ant.apache.org
>
>

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message