ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Eric Wulff <>
Subject can't get optional scp to work - ant 1.6.2
Date Mon, 21 Nov 2005 19:35:15 GMT
Hi, I'm trying to run the optional scp task (ant 1.6.2 - java 1.4.2)
but it's complaining.  I feel I've covered the most likely problems
and now I'm running around with my head cut off  :).

- my usr/local/ant is in my path
- I have verified the jsch.jar dependency in my ant.home/lib (I've
tried adding it to my classpath as well, which seems redundant, but
this didn't help)
- I have verified that there is more than just a manifest in the .jar

I ran diagnostics and got the following missing dependency...

scp : Missing dependency com.jcraft.jsch.UserInfo

Does that mean ant isn't seeing the jsch.jar at all or that the .jar
is missing something?


ant output...

Ant could not find the task or a class this task relies upon.

This is common and has a number of causes; the usual
solutions are to read the manual pages then download and
install needed JAR files, or fix the build file:
  - You have misspelt 'scp'.
   Fix: check your spelling.
 - The task needs an external JAR file to execute
     and this is not found at the right place in the classpath.
   Fix: check the documentation for dependencies.
   Fix: declare the task.
 - The task is an Ant optional task and the JAR file and/or libraries
     implementing the functionality were not found at the time you
     yourself built your installation of Ant from the Ant sources.
   Fix: Look in the ANT_HOME/lib for the 'ant-' JAR corresponding to the
     task and make sure it contains more than merely a META-INF/MANIFEST.MF.
     If all it contains is the manifest, then rebuild Ant with the needed
     libraries present in ${ant.home}/lib/optional/ , or alternatively,
     download a pre-built release version from
 - The build file was written for a later version of Ant
   Fix: upgrade to at least the latest release version of Ant
 - The task is not an Ant core or optional task
     and needs to be declared using <taskdef>.
 - You are attempting to use a task defined using
    <presetdef> or <macrodef> but have spelt wrong or not
   defined it at the point of use

Remember that for JAR files to be visible to Ant tasks implemented
in ANT_HOME/lib, the files must be in the same directory or on the

Please neither file bug reports on this problem, nor email the
Ant mailing lists, until all of these causes have been explored,
as this is not an Ant bug.

To unsubscribe, e-mail:
For additional commands, e-mail:

View raw message