ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Erin Gu" <...@noteworthyms.com>
Subject RE: Ant fails to delete jars under "lib"
Date Tue, 01 Nov 2005 18:27:54 GMT
I just found this:
http://issues.apache.org/bugzilla/show_bug.cgi?id=28046

It might be Ant who automatically added "./lib" to its CLASSPATH, so the
jars can't be deleted?

Erin


>-----Original Message-----
>From: Jeffrey E Care [mailto:carej@us.ibm.com]
>Sent: Tuesday, November 01, 2005 11:41 AM
>To: Ant Users List
>Subject: Re: Ant fails to delete jars under "lib"
>
>
>Perhaps some process was using that JAR at the time you attempted to
>delete it?
>
>--
>Jeffrey E. Care (carej@us.ibm.com)
>WebSphere v7 Release Engineer
>WebSphere Build Tooling Lead (Project Mantis)
>
>
>"Erin Gu" <egu@noteworthyms.com> wrote on 11/01/2005 11:28:46 AM:
>
>> Hi, I try to use <delete dir="lib"/> to delete a group of jars, then I
>got
>> an error:
>>
>> test:
>>    [delete] Deleting: C:\sysbuild\ccc\NW-RI\Ped\2.0\dev\lib\erin.jar
>>
>> BUILD FAILED
>> C:\sysbuild\ccc\NW-RI\Ped\2.0\dev\build-portal.xml:13: Unable to delete
>file
>> C:\sysbuild\ccc\NW-RI\Ped\2.0\dev\lib\erin.jar
>>
>> The I changed the dir name from "lib" to something else, it is ok.
>>
>> test:
>>    [delete] Deleting: C:\sysbuild\ccc\NW-RI\Ped\2.0\dev\lib1\erin.jar
>> BUILD SUCCESSFUL
>>
>>
>> I am using Ant 1.6.1. Is this a known Ant bug? Any workaround? Thanks in
>> advance.
>>
>> Erin
>>
>>
>> ---------------------------------------------------------------------
>> To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
>> For additional commands, e-mail: user-help@ant.apache.org
>>
>


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message