ant-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Nadejda Rylova <nadejda.ryl...@gmail.com>
Subject RE: <exec> and '$' symbol on Solaris 8
Date Fri, 25 Nov 2005 06:26:50 GMT
Dominique,

I tried to simplify the task description (and as you can see this reductive
variant of the task had to be explained with several letters). Actually
there were several ssh-scripts (not only ProductIndexer) and... I executed
them not from command line but from other sh-file that just (as I really
believed) call all these scripts one by one with some echo-comment between
them. And it's the case excepted for three lines:
 
EAHOME=/opt/EasyAsk
DNAME=tshipley
export LANG=en_US.ISO8859-1

I just overlooked one of them. It's my fault.
Sorry for this little cheating.

Nadejda



-----Original Message-----
From: Dominique Devienne [mailto:ddevienne@gmail.com] 
Sent: Tuesday, November 22, 2005 8:28 PM
To: Ant Users List
Subject: Re: <exec> and '$' symbol on Solaris 8

> FIXED!!! The point is the environment variable LANG.
>
> ProductIndexer connects to Oracle DB during its work. For right work of
> oracle database connection it is necessary to indicate language. New
> property shall be added:
>        <property name="LANG" value="en_US.ISO8859-1"/>
>        <exec ... >
>            <env key="LANG" value="${LANG}"/>
>        </exec>

Hmmm, AFAIK a child process inherits its parent process environment,
so if you were able to run the command in a shell OK, it implies that
LANG was defined correctly, so running Ant from the same shell should
also have worked, no?

You could test this by <exec>ing the env command and see if the LANG
var set on the parent shell (or not) is listed in the output of the
<exec>'d env (or not).

It's good that you fixed it, but this is puzzling nonetheless ;-) --DD

---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


---------------------------------------------------------------------
To unsubscribe, e-mail: user-unsubscribe@ant.apache.org
For additional commands, e-mail: user-help@ant.apache.org


Mime
View raw message